Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got the DOSBox SVN-Duam from its homepage. Maybe I have solved the dependency problems,

$ ldd ./dosbox => (0xb776d000) => /usr/lib/ (0xb7707000) => /usr/lib/i386-linux-gnu/ (0xb7615000) => /lib/i386-linux-gnu/ (0xb760f000) => /lib/i386-linux-gnu/ (0xb75f4000) => /usr/lib/i386-linux-gnu/ (0xb7559000) => /lib/i386-linux-gnu/ (0xb752f000) => /lib/i386-linux-gnu/ (0xb7519000) => /usr/lib/i386-linux-gnu/ (0xb747e000) => /usr/local/lib/ (0xb7442000) => /usr/lib/i386-linux-gnu/ (0xb743d000) => /usr/lib/i386-linux-gnu/ (0xb7309000) => /usr/lib/nvidia-current-updates/ (0xb722d000) => /usr/lib/i386-linux-gnu/ (0xb7167000) => /usr/lib/ (0xb713c000) => /usr/lib/i386-linux-gnu/ (0xb7057000) => /lib/i386-linux-gnu/ (0xb702b000) => /lib/i386-linux-gnu/ (0xb700d000) => /lib/i386-linux-gnu/ (0xb6e62000) => /usr/lib/i386-linux-gnu/ (0xb6e58000) => /lib/i386-linux-gnu/ (0xb6e4f000)
    /lib/ (0xb776e000) => /usr/lib/i386-linux-gnu/ (0xb6e4a000) => /usr/lib/i386-linux-gnu/ (0xb6dfc000) => /usr/lib/i386-linux-gnu/ (0xb6de9000) => /usr/lib/i386-linux-gnu/ (0xb6d1e000) => /usr/lib/i386-linux-gnu/ (0xb6cfd000) => /usr/lib/nvidia-current-updates/tls/ (0xb6cf9000) => /usr/lib/nvidia-current-updates/ (0xb4ff3000) => /lib/i386-linux-gnu/ (0xb4ef9000) => /usr/lib/i386-linux-gnu/ (0xb4edb000) => /usr/lib/i386-linux-gnu/ (0xb4e69000) => /lib/i386-linux-gnu/ (0xb4e20000) => /lib/i386-linux-gnu/ (0xb4de6000) => /usr/lib/i386-linux-gnu/ (0xb4dba000) => /usr/lib/i386-linux-gnu/ (0xb4db2000) => /usr/lib/i386-linux-gnu/ (0xb4d4d000) => /usr/lib/i386-linux-gnu/ (0xb4d45000) => /lib/i386-linux-gnu/ (0xb4c25000) => /lib/i386-linux-gnu/ (0xb4bf4000) => /lib/i386-linux-gnu/ (0xb4bd5000) => /usr/lib/i386-linux-gnu/ (0xb4bd1000) => /usr/lib/i386-linux-gnu/ (0xb4bca000) => /lib/i386-linux-gnu/ (0xb4b8e000) => /usr/lib/i386-linux-gnu/ (0xb4b3f000) => /usr/lib/i386-linux-gnu/ (0xb49c7000) => /lib/i386-linux-gnu/ (0xb49bd000) => /usr/lib/i386-linux-gnu/ (0xb49b6000) => /lib/i386-linux-gnu/ (0xb499c000) => /lib/i386-linux-gnu/ (0xb4983000)

But when I run it,

$ ./dosbox

DOSBox version SVN-Daum

Copyright 2002-2011 DOSBox Team, published under GNU GPL.

GUI: Press Ctrl-F10 to capture/release mouse, Alt-F10 for configuration. CONFIG:Loading primary settings from config file dosbox.conf ./dosbox: symbol lookup error: ./dosbox: undefined symbol: SDL_GetDesktopMode

What's wrong with it? I haven't tried to run it on other Linux distributions. But it's perfect on Windows.

share|improve this question

You can find in LIBS directory. The file includes a function called SDL_GetDesktopMode.

If you are going to compile SDL yourself, you need Moe's openglhq patch. Get openglhq-dosbox-for-sdl-202121117_msvc_gcc.patch from his website.

share|improve this answer
The problem is solved under your help. Thank you very much! – Startmenu Apr 22 '13 at 14:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.