Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Scenario

Recently I build up my own desktop and decided to install as first OS Windows 8 (why did I do that...) as always I have both, Ubuntu and Windows, I though that installing Windows first would be better to check if my video card was working properly as drivers works better in Windows.

Problem

The problem is that when I installed Ubuntu after restarting the PC I won't be prompted to choose an OS, it simply starts Windows 8. Then I read about Windows 8 installation and found out that it uses UEFI boot as there is a partition created by Windows that is EFI.

Then I tried to install Ubuntu EFI although I got the very same situation. After that I did a last try making things manually by selecting the partition that Windows created as EFI partition, although the installation couldn't proceed because it didn't identified the EFI partition as an EFI partition.

What I want

I wonder if I delete the partition that Windows created as EFI and let Ubuntu create it's own EFI in the place will things work?

But if that isn't possible I don't want Windows 8 anymore in my PC, I will stick with 7 and Ubuntu, but as I don't know a lot about UEFI stuff I am wondering if I just make a backup partition for my important files in NTFS system and delete all the rest and then install Ubuntu and after Windows 7 it will work.

Because I don't know if Windows 8 configurations into the UEFI BIOS will remain after deleting it from the HDD and it will prevent me from installing other OS'es and then I will be with no computer at all.

In addition I would like to have Ubuntu and Windows 7 installed both as EFI systems if possible cause as far as I know it improves security (correct me if I am wrong) and my motherboard doesn't support Secure Boot it has any option about that in the BIOS and I ran Confirm-SecureBootUEFI command in Windows that returned that my system doesn't support Secure Boot.

My PC Specs

  • CORSAIR Vengeance LP 8GB (2 x 4GB) DDR3 1333 (PC3 10666) (CML8GX3M2A1333C9)

  • GIGABYTE Radeon HD 7970 3GB 384-bit GDDR5 PCI Express 3.0 x16 (GV-R797OC-3GD)

  • Intel Core i5-3570 Ivy Bridge 3.4GHz (3.8GHz Turbo) LGA 1155 77W Quad-Core (BX80637I53570)

  • GIGABYTE GA-B75M-D3H Dual-UEFI LGA 1155 Intel B75 HDMI SATA 6Gb/s USB 3.0 Micro ATX (GA-B75M-D3H)

  • Seagate Barracuda 1TB 7200 RPM 32MB Cache SATA 6.0Gb/s 3.5" (ST31000524AS)

Additional Info

As suggested by user Rod Smith I ran Boot Info Script in the live usb of raring daily build, the content of the file RESULTS.txt is here:

                  Boot Info Script 0.61      [1 April 2012]


============================= Boot Info Summary: ===============================

 => Windows is installed in the MBR of /dev/sda.
 => Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Boot/BCD

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Windows/System32/winload.exe

sda3: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 13.04
    Boot files:        /boot/grub/grub.cfg /etc/fstab

sda4: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 4.04 2011-04-18
    Boot sector info:  Syslinux looks at sector 1628296 of /dev/sdb1 for its 
                       second stage. SYSLINUX is installed in the  directory. 
                       The integrity check of the ADV area failed. No errors 
                       found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg /syslinux/syslinux.cfg 
                       /efi/BOOT/grubx64.efi /ldlinux.sys

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1    *          2,048       718,847       716,800   7 NTFS / exFAT / HPFS
/dev/sda2             718,848   921,599,999   920,881,152   7 NTFS / exFAT / HPFS
/dev/sda3         921,600,000 1,945,693,749 1,024,093,750  83 Linux
/dev/sda4       1,945,694,208 1,953,523,711     7,829,504  82 Linux swap / Solaris


Drive: sdb _____________________________________________________________________

Disk /dev/sdb: 4051 MB, 4051697152 bytes
125 heads, 62 sectors/track, 1021 cylinders, total 7913471 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sdb1    *             62     7,912,749     7,912,688   b W95 FAT32


"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0                                              squashfs   
/dev/sda1        4664C9EB64C9DE35                       ntfs       Reservado pelo Sistema
/dev/sda2        8A46D14C46D13A21                       ntfs       
/dev/sda3        3372315d-d1df-4670-bcbb-4a4ab5548b09   ext4       
/dev/sda4        d5f3ad90-fa34-4a62-9adc-efc3fdd3bfce   swap       
/dev/sdb1        B656-E464                              vfat       MYLINUXLIVE

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /rofs                    squashfs   (ro,noatime)
/dev/sda2        /media/ubuntu/8A46D14C46D13A21 fuseblk    (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1        /cdrom                   vfat       (ro,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)


=========================== sda3/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos3'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  3372315d-d1df-4670-bcbb-4a4ab5548b09
else
  search --no-floppy --fs-uuid --set=root 3372315d-d1df-4670-bcbb-4a4ab5548b09
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=pt_BR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
  clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
    set gfxpayload="${1}"
    if [ "${1}" = "keep" ]; then
        set vt_handoff=vt.handoff=7
    else
        set vt_handoff=
    fi
}
if [ "${recordfail}" != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
menuentry 'Ubuntu' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-3372315d-d1df-4670-bcbb-4a4ab5548b09' {
recordfail
    load_video
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='hd0,msdos3'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  3372315d-d1df-4670-bcbb-4a4ab5548b09
    else
      search --no-floppy --fs-uuid --set=root 3372315d-d1df-4670-bcbb-4a4ab5548b09
    fi
    linux   /boot/vmlinuz-3.8.0-19-generic root=UUID=3372315d-d1df-4670-bcbb-4a4ab5548b09 ro   quiet splash $vt_handoff
    initrd  /boot/initrd.img-3.8.0-19-generic
}
submenu 'Opções avançadas para Ubuntu' $menuentry_id_option 'gnulinux-advanced-3372315d-d1df-4670-bcbb-4a4ab5548b09' {
    menuentry 'Ubuntu, com Linux 3.8.0-19-generic' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.8.0-19-generic-advanced-3372315d-d1df-4670-bcbb-4a4ab5548b09' {
    recordfail
        load_video
        gfxmode $linux_gfx_mode
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos3'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  3372315d-d1df-4670-bcbb-4a4ab5548b09
        else
          search --no-floppy --fs-uuid --set=root 3372315d-d1df-4670-bcbb-4a4ab5548b09
        fi
        echo    'Carregando Linux 3.8.0-19-generic ...'
        linux   /boot/vmlinuz-3.8.0-19-generic root=UUID=3372315d-d1df-4670-bcbb-4a4ab5548b09 ro   quiet splash $vt_handoff
        echo    'Carregando ramdisk inicial ...'
        initrd  /boot/initrd.img-3.8.0-19-generic
    }
    menuentry 'Ubuntu, com Linux 3.8.0-19-generic (modo de recuperação)' --class ubuntu --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-3.8.0-19-generic-recovery-3372315d-d1df-4670-bcbb-4a4ab5548b09' {
    recordfail
        load_video
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos3'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  3372315d-d1df-4670-bcbb-4a4ab5548b09
        else
          search --no-floppy --fs-uuid --set=root 3372315d-d1df-4670-bcbb-4a4ab5548b09
        fi
        echo    'Carregando Linux 3.8.0-19-generic ...'
        linux   /boot/vmlinuz-3.8.0-19-generic root=UUID=3372315d-d1df-4670-bcbb-4a4ab5548b09 ro recovery nomodeset 
        echo    'Carregando ramdisk inicial ...'
        initrd  /boot/initrd.img-3.8.0-19-generic
    }
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Windows 8 (loader) (em /dev/sda1)' --class windows --class os $menuentry_id_option 'osprober-chain-4664C9EB64C9DE35' {
    insmod part_msdos
    insmod ntfs
    set root='hd0,msdos1'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  4664C9EB64C9DE35
    else
      search --no-floppy --fs-uuid --set=root 4664C9EB64C9DE35
    fi
    drivemap -s (hd0) ${root}
    chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
--------------------------------------------------------------------------------

=============================== sda3/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda3 during installation
UUID=3372315d-d1df-4670-bcbb-4a4ab5548b09 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda4 during installation
UUID=d5f3ad90-fa34-4a62-9adc-efc3fdd3bfce none            swap    sw              0       0
--------------------------------------------------------------------------------

=================== sda3: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

               =                boot/grub/grub.cfg                             1
               =                boot/initrd.img-3.8.0-19-generic               1
               =                boot/vmlinuz-3.8.0-19-generic                  1
               =                initrd.img                                     1
               =                vmlinuz                                        1

=========================== sdb1/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------

if loadfont /boot/grub/font.pf2 ; then
    set gfxmode=auto
    insmod efi_gop
    insmod efi_uga
    insmod gfxterm
    terminal_output gfxterm
fi

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

menuentry "Try Ubuntu without installing" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
    initrd  /casper/initrd.lz
}
menuentry "Install Ubuntu" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash --
    initrd  /casper/initrd.lz
}
menuentry "OEM install (for manufacturers)" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true --
    initrd  /casper/initrd.lz
}
menuentry "Check disc for defects" {
    set gfxpayload=keep
    linux   /casper/vmlinuz.efi  boot=casper integrity-check quiet splash --
    initrd  /casper/initrd.lz
}
--------------------------------------------------------------------------------

========================= sdb1/syslinux/syslinux.cfg: ==========================

--------------------------------------------------------------------------------
# D-I config version 2.0
include menu.cfg
default vesamenu.c32
prompt 0
timeout 50
ui gfxboot bootlogo
--------------------------------------------------------------------------------

=================== sdb1: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

            ?? = ??             boot/grub/grub.cfg                             1

================= sdb1: Location of files loaded by Syslinux: ==================

           GiB - GB             File                                 Fragment(s)

            ?? = ??             ldlinux.sys                                    1
            ?? = ??             syslinux/chain.c32                             1
            ?? = ??             syslinux/gfxboot.c32                           1
            ?? = ??             syslinux/syslinux.cfg                          1
            ?? = ??             syslinux/vesamenu.c32                          1

============== sdb1: Version of COM32(R) files used by Syslinux: ===============

 syslinux/chain.c32                 :  COM32R module (v4.xx)
 syslinux/gfxboot.c32               :  COM32R module (v4.xx)
 syslinux/vesamenu.c32              :  COM32R module (v4.xx)

=============================== StdErr Messages: ===============================

awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
/home/ubuntu/Documents/bootinfoscript: line 1646: [: 2.73495e+09: integer expression expected
  No volume groups found
share|improve this question

marked as duplicate by Luis Alvarado Mar 4 at 17:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please run the Boot Info Script (sourceforge.net/projects/bootinfoscript) from the Ubuntu "try before installing" mode. This will create a file called RESULTS.txt. Post a link to this file here; it contains vital diagnostic information that's necessary to do more than speculate about causes. –  Rod Smith Apr 20 '13 at 18:25
    
With the new info provided, We can start looking for any issues with that hardware and Ubuntu. Thanks for the update Rodrigo. –  Luis Alvarado Apr 21 '13 at 21:49
    
You're welcome, I just think that deleting my comment replying to @LovinBuntu wasn't right, so just stating here what was on the comment: I ran the Recommended Repair without internet connecting, so I didn't got any URL. –  Rodrigo Martins Apr 21 '13 at 22:03
    
My 12.10 install doesn't even SEE Win 8 (64 bit) with EFI install; it wants to blow away my ENTIRE 500 gb. drive. Any suggestions? Tried Legacy BIOS mode already with same results, and I can't afford to let it blow away that entire partition. By the way, Rodrigo, if you'd like to make Windows 8 act like it SHOULD, checkout 'Classic Shell'. It makes Win 8 fairly nice. ;-) –  user151149 Apr 22 '13 at 2:00
    
Hi @RodrigoMartins I have updated the marked duplicate question with several steps to fix Dual Boot issues. This are tested and work correctly for cases like yours apply –  Luis Alvarado Mar 4 at 17:01
show 1 more comment

2 Answers 2

up vote 2 down vote accepted

It looks like you've got a BIOS-mode installation of Windows -- your disk is partitioned using the MBR scheme, not GPT as would be required for an EFI-mode installation; and there's a copy of the Windows boot loader in the MBR of the disk. It looks like you've got a reasonable grub.cfg file in your Linux partition, although I've not studied every last line of it; but it looks like something went wrong with the GRUB setup, since there's no trace of GRUB in the hard disk's MBR.

Chances are the Ubuntu Boot Repair tool will be able to get things working, although I can't promise that. If you run it and have problems, post back, since there are manual procedures that will almost certainly work, too.

share|improve this answer
    
I didn't know about Ubuntu Boot Repair tool, although I used it and I got no results. It says in the log file that everything seems to be okay and then appears that boot was repaired, but I am still with the very same problems. If you can help me on the manual process that you sad I would be thanked. –  Rodrigo Martins Apr 21 '13 at 15:00
    
You need to boot an Ubuntu emergency CD and use the grub-install program. The procedure is detailed at help.ubuntu.com/community/Grub2/…. –  Rod Smith Apr 21 '13 at 17:54
    
I used grub-install as recommended and this lead me to a grub rescue at system start, then I was not even able to start Windows. So I used Boot-Repair and set it to restore MBR and now I am able to start Windows 8 again. So I came back to same situation where I started. –  Rodrigo Martins Apr 21 '13 at 21:57
    
Hey, it kind of worked with Ubuntu 13.04! I downloaded it today in the hope that something changes, installed and again the very same problem, then I though let's give one more chance to Boot-Repair Tool, installed it into the LiveUSB and ran it, Two words: Just worked! Thanks @RodSmith !!! –  Rodrigo Martins Apr 25 '13 at 16:17
add comment

it may be caused by many reasons but definitely not Windows 8 because I use both Win8 and Ubuntu 13.04


You may have a bad disk. If so, you need to set /boot as a separate partition(/dev/sda1) and put it at the head of the disk.


You may failed to install grub. if so, type grub-install /dev/sda in terminal in a livecd or try a software called "easybcd" under windows.


If your mbr was overwritten by Windows, you may just try sudo -i mount /dev/sda[#] /mnt grub-install --root-directory=/mnt/ /dev/sda in livecd. (/dev/sda[#] is where you / directory is)


hope you can solve your problem as soon as possible.

share|improve this answer
    
I tried easybcd, athough it didn't solved anything, I tried to use grub-install /dev/sda and it lead me to a grub prompt at the boot of the pc, then I tried your 4th solution, that is written wrong or may be old, the correct code is here: help.ubuntu.com/community/Grub2/… and then after that I got at grub rescue prompt. –  Rodrigo Martins Apr 21 '13 at 21:55
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.