Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to make my Dlink DWA-111 work on Ubuntu 12.10 in vmware workstation. since Vmware doesn't recognize my integrated wifi card as a wifi card, I changed to a USB one. This one is recognized in windows 8, but when I launch my Ubuntu VM, it doesn't work at all. I'm still getting connected.

Disabling the USBb from the host and activating it on the Vm:

lsusb

shows me the dlink usb card

> lsmod

show me the rt73 module

>iwconfig, ifconfig, iwlist

shows nothing.

I tried many solutions found on Google and forums as compiling drivers, getting ndiswrapper, ndisgtk. ndiswrapper -l shows me my driver with the ID of the device but when I enter sudo modprobe ndiswrapper I got:

FATAL:Module ndiswrapper not found.

and still no wifi on my Ubuntu.

Any assistance will be greatly appreciated.

share|improve this question

1 Answer 1

When I run Ubuntu 13.10 on my Toshiba L55 with an RTL-8188EE it works fine, however when I started it in VMWare the wireless card did not appear to be found.

The solution that worked for me was to go in to the VMWare Settings for Network, and change Adapter 1 to Bridged Adapter instead of NAT. I then saw the Wireless adapter, said OK to save the changes and it worked fine after that

Hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.