Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I save a document in LibreOffice and try to open it in Office 2007 for example, most or all of the paragraphs moved somehow. For what I found out is that the document has Widows and Orphans. How do I fix this so the document can be seen 100% accurate in Office 2007, 2003, OpenOffice and LibreOffice? What tips do askubuntu suggest about creating a compatible document between them (even though you know the non-standard approach of Office 2007 in this)?

share|improve this question

3 Answers 3

up vote 10 down vote accepted

It is almost impossible to have 100% compatibility, however, if you are not using wordart/libreoffice draw features, etc, you can get high levels of compatibility by using a few simple things:

  • Save your documents in a format that all the listed office suites can use (MS Office 2003 documents are best for this purpose, and more so with Word Processing documents).
  • Only use features that are shared between the applications, so for example, use simple formatting in tables (*by simple, I mean, just create a standard table, X*Y dimensions, without adding excel features etc, which can become complicated*).
  • Use fonts that are available in all the suites. Missing fonts can produce problems.
  • Use the program options to your advantage :)! I do not have office installed, but I do have LibreOffice. So for example, you can set up the Load/Save options as such: LibreOffice Load/Save Options You can access this dialog by clicking tools>options in the menu.
share|improve this answer
    
I did not know that feature in the picture. Thanks. –  Luis Feb 27 '11 at 21:03

Personally, I have found that using the .doc file format in LibreOffice improves compatibility with MS office.

Also, install the newest service pack for Office 2007 because it will add .odt file format support to Office. Odt is the default format of LibreOffice and OpenOffice.

I also know that using 1.5 line spacing sometimes lead to compatibility issues between Libreoffice and MS.

For Writer, go to options->LibreOffice Writer->compatibility and select the "do not add leading space (extra space) between lines of text" and the "consider wrapping style when positioning objects."

Lastly, LibreOffice has much better support for MS office file formats than OpenOffice.

share|improve this answer

One format almost 100% compatible between Ms Office and opensource applications is RTF. One issue is the files get bigger usually.

share|improve this answer
    
-1 answer, why? –  el_Salmon Dec 3 '12 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.