Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to update to 12.10, but in the mist of installing, the entire computer froze, and not knowing about REISUB I forced quit my computer

Ever since, every time I updated, I was given a message that said to do a partial install (which I ignored. And a dialog box that said to run a command to fix the software updater. I would update the software, and halfway though installation, the computer would freeze, again

I repeated this thinking that next time this wouldn't happen, but after I rebooted, the desktop seemed broken, appearing only as a back screen that would act like an old frozen windows XP computer (in that when you move a application around the screen, it 'paints' a picture of the application on the desktop)

I tried again, it froze, and I REISUB

I tried again, it froze, and I REISUB

now, I'm at a blue screen of death. The entire screen is blue. But all of the processes still work, i just cant get to them without a keyboard shortcut.

So how do I fix this disastrous mess?

Oh, one more thing, it seems like the system is in this weird state where half of it is in 12.04 and half of its in 12.10, ever since the first try at updating failed. The login screen says that I'm in 12.04, but the ctrl-alt-f1 terminal says I'm in 12.10

share|improve this question

marked as duplicate by Jorge Castro, Eric Carvalho, Basharat Sialvi, bcbc, green7 Apr 21 '13 at 9:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

Try going into "recovery mode" from the GRUB boot. Then, run the following commands:

sudo apt-get update
sudo apt-get upgrade

and see if that gets you any more progress. If not, let us know what error output messages you get.

share|improve this answer
    
What do I select in the recovery menu? –  nmd Apr 20 '13 at 8:35
    
Judging by the errors I received, it can't update because its not connected to the Internet (I'm in the root shell prompt) –  nmd Apr 20 '13 at 8:59
    
Ok, I logged in not in recovery mode and went to the ctrl-alt-F1 terminal and ran those commands. At sudo apt-update it gave me an output of 373 packages that have been kept back. I'm pretty sure those packages are important, so how do I install them? –  nmd Apr 20 '13 at 9:15
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.