Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In order to access some privileges as far as accessing journal articles and other resources that my university allows me I need cookies enabled. I have tried what I can to enable them like going to the Opera -> Settings -> Quick Preferences -> Enable Cookies (and clicking this) but this doesn't seem to do a thing.

share|improve this question
add comment

1 Answer

Opera has several settings concerning cookies. The quick preferences are what you can commonly also access via F12 when on a website. The quick preferences are there to toggle particular settings quickly and conveniently without having to go into some configuration dialog.

However, if your global Opera settings regarding cookies are set too restrictive, this would likely be where to look first. The three settings I marked in the following screenshot are the most important:

Opera cookie preferences

Invoke the preferences dialog with Ctrl+F12 and then go to the "Advanced" tab and navigate to the "Cookies" settings from there.

Failing that, there is another place you can look for too restrictive cookie settings. That's when you press F12 again on the website and then choose the (by default) item at the bottom "Edit Site Preferences". This has a "Cookies" tab with similar settings are the global ones shown in the global settings:

Site preferences: cookie settings

Failing all of the above, which is what you will need if you have no extensions or user scripts installed, I would review my user scripts and extensions, turn them off one by one and then check whether the web site works.


If you still have no luck, try to tell Opera to pose as one of the other browsers. Some web sites are particular to browsers and make (wrong!) assumptions based on their own browser detection code. You can change that in the site preferences again ("Network" tab):

Site preferences: "Network" tab

share|improve this answer
    
Unfortunately many of these suggestions I can't try very well until I have this problem askubuntu.com/questions/283252/… addressed. –  Brenton Horne Apr 19 '13 at 16:59
1  
@BrentonHorne: for the other issue, you seem to be using Unity, I'd try to wiggle a terminal window or something else in front of the Opera dialog. Opera does a lot of the drawing not based on what the OS provides, but brings its own means to do that. So you need to convince it somehow to redraw. I've actually never encountered the problem you are showing there in my entire 15 years of Opera use. –  0xC0000022L Apr 19 '13 at 17:03
    
Just tried that and it failed. –  Brenton Horne Apr 19 '13 at 17:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.