Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've tried using mupen64plus and project64 2.0 under wine, but both have failed to run correctly. The video is completely blank, although the audio seems to run fine. Even when I fullscreen the project64 window, it still remains blank, only changing colour from black to white.

I've tried various video plugins, including arachnoid, z64, rice, glide64, etc.

Rice comes the closest, by showing small parts of the screen, with the rest being totally blank.

Glide64 outputs an error message:

Video: ucode = -1
Video Error: Error: Unsupported uCode!
crc: 86b1593e

I've also tried the different available varieties of the game, the USA and European versions, but to no avail.

Not sure where to go from there.

Edit: I'm using nvidia proprietary drivers and have had no problem running other games in both mupen64plus and project64 2.0.

share|improve this question
add comment

1 Answer 1

Do your current drivers support 3D acceleration? If you're running other games in Wine, then the answer is likely yes. If you aren't, or you don't know or otherwise want a sanity check, open terminal and run glxgears. For modern graphics cards, the gears demo should run, and the output should show an FPS well over 1000.

If your current drivers don't support 3D acceleration, you'll need to install ones that do. This will depend on your card, but generally, the easiest way is to install the proprietary drivers. You can find them in the "Drivers" tab of the "Additional Software Sources" app.

Have you tried PlayOnLinux? PlayOnLinux is a wrapper for Wine that's available in the respositories. It can aid in getting games to work by installing specific versions of Wine (they don't overwrite one another) that are known to work best for the application in question. Often, this is one of the easiest ways to get a game working.

share|improve this answer
    
Yes, I'm using nvidia drivers and am able to play every other game I've tried to. It's only this game which is being so problematic. –  shafty Apr 19 '13 at 17:43
    
Have you tried PlayOnLinux? If not, try it. Also, a quick search on WineHQ for reviews of the game shows that it has, at best, a bronze rating. The reviews for it are old, though, so it's possible the things keeping it from working have since been fixed. However, that should be something to keep in mind. –  Shauna Apr 19 '13 at 19:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.