Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using now 13.04 and sound 5.1 doesn't work well, only the 2 front speakers work, in Ubuntu 12.10 work all good all speakers play. I am using the USB sound card sweex SC016.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

1. Two active soundcards

There are two active sound cards in a computer: one on the motherboard and a separate PCI sound card. Or a built-in old-fashioned phone modem: that has it's own sound chip, for making calling sounds.

In certain rare cases, Ubuntu has a problem with the presence of multiple active sound cards. Then it's therefore best, to have only one active sound card.

Solution: disable the on-board card in the BIOS. After you reboot your computer, the sound will come entirely through the PCI card.

If you can't find the disabling option of the on-board sound card in the BIOS, search the Internet for the manual for your motherboard.

2. The volume may not be right or too few sound channels are opened.

A. Install pavucontrol by means of Ubuntu Software Center.

B. Now start pavucontrol. Check the position of the sound channel sliders.

3. Install alsamixer and try this sudo alsa force-reload .

4. If none of the above work,try this. Just open the terminal and copy these commands.

sudo add-apt-repository -y ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get dist-upgrade

sudo apt-get -y install linux-sound-base alsa-base alsa-utils libasound2

sudo apt-get -y install gdm ubuntu-desktop linux-image-`uname -r`

sudo apt-get -y --reinstall install libasound2 linux-sound-base alsa-base alsa-utils

sudo apt-get -y --reinstall lightdm ubuntu-desktop linux-image-`uname -r`

killall pulseaudio

rm -r ~/.pulse*

sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

When you finish, restart your system. If sound still missing from your system, you can check this article we published some months ago. If you have something to add, please do by commenting below.

share|improve this answer
    
killall pulseaudio would have been responsible for making the card work properly, regardless of the content of the PPA. Therefore I would recommend renaming point 4 to point 5 and add point 4 with just pulseaudio -k. –  LiveWireBT Apr 19 '13 at 21:22
    
for me, pavucontrol made the things. I disabled the on-board audio in pavucontrol, and selected 5.1 device for my external one –  Seer Jul 21 '13 at 21:41

Some external sound cards are not detected properly by PulseAudio the first time and you only get the stereo profiles to choose from. In that situation killing PulseAudio with pulseaudio -k and waiting for it to restart helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.