Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I attach the external hard drive, the folders have a lock icon on them and i am unable to delete them.

I tried to use sudo chown -R $USER:$USER $HOME but to no avail, this did not work. Please tell how to remove that icon and edit the read-only permission.

share|improve this question
    
Were those files created in Windows environment? –  thefourtheye Apr 19 '13 at 13:43
    
No, but they were transferred to hard drive in windows platform. –  Saket Apr 19 '13 at 14:01
    
Are you able to open those files? –  thefourtheye Apr 19 '13 at 14:15
    
yes,able to copy and paste new files but unable to delete files –  Saket Apr 22 '13 at 4:09
add comment

1 Answer

This generally happens when using an NTFS-formatted drive and is due to how NTFS/Windows handles file permissions (in short, not how the *nix world does it).

You have to adjust your fstab settings to mount the drive with appropriate permissions. This related question has more details, but the basics of it are that you want to set the uid and gid values to your user and group. This mounts it as your user, instead of as root.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.