Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I am more than a couple of metres from my access point (and I'm seeing this across various APs) with my newish Thinkpad Edge 15, running 10.10, the wifi performance becomes ... flaky. When this is happening, I see the following in dmesg, although I'm not sure if it's related:

[ 2497.011099] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2502.012711] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2507.009254] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2512.008367] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2517.007467] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2522.006558] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2527.008157] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2532.007251] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2537.003838] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2542.005427] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2547.004496] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded
[ 2552.003611] intel ips 0000:00:1f.6: CPU power or thermal limit exceeded

lspci -vvv has the following to say about my wireless adapter:

03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
        Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 49
        Region 0: Memory at f0500000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn

If I get within a couple of metres of the access point, I still see that output in dmesg, but the connection stabilises.

My question is threefold: how do I get better wifi range, what can/should I do about those messages in dmesg, and most crucially, are the two related?

As ever let me know if there's other information that would help!

Edit: I am using this machine in exactly the same locations I used my previous Thinkpad (T61) running various older versions of Ubuntu, so I definitely feel there is something wrong, rather me having unreasonable expectations of range!

share|improve this question
    
Related to @aking1012's question, was your previous Thinkpad using wireless N? –  belacq Mar 2 '11 at 7:58
    
@jgbelacqua it wasn't using it routinely, whether it had it enabled I couldn't say -- my great joy with Ubuntu/Thinkpad as a pairing is that I don't have to care about this stuff on my own machine and can just get on with coding and/or supporting my users, without struggling myself :) –  James Green Mar 3 '11 at 2:54
    
intel ips 0000:00:1f.6: CPU power or thermal limit exceeded means your computer is overheating. –  Mechanical snail May 27 '13 at 8:59
    
@Mechanicalsnail unfortunately that clearly wasn't the case at the time. Also I'd be unlikely to ask on here before confirming "thermal limit exceeded" didn't relate to a simple overheating issue! If anything, I may have been hitting a CPU power threshold -- i.e. the other half the error message. More likely there was a bug in a driver somewhere... Anyway it was 2 years ago, and the hardware is long since retired :-) –  James Green May 27 '13 at 18:59

1 Answer 1

Turn off wireless N. It's still finicky on intel chipsets. If you did some other custom stuff(like turn off hardware crypto for injection) then it's not a real issue and consider it a side effect of your tweaks.

modprobe -r iwlagn
modprobe iwlagn 11n_disable=1
should disable it...
modprobe iwlagn 11n_disable=0
should enable it...

then if toggling solves your problem in /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf
options iwlagn 11n_disable=1
or
options iwlagn 11n_disable=0

whatever solved your problem

share|improve this answer
    
I've done no tweaking; previously things have Just Worked, and this is why I like both Ubuntu and Thinkpads ;) I can't see an obvious way to turn N off and only use b/g... what I missing? –  James Green Mar 3 '11 at 2:51
    
any specific method you'd recommend to turn off wireless N? –  belacq Mar 27 '11 at 5:25
    
@jgbelecqua check the edit. it shipped disabled out of the box for me, but you never know if someone cut and pasted a tutorial somewhere. –  hbdgaf Mar 27 '11 at 7:00
    
I'm now, unhelpfully, on 11.04. modprobe -r then disabling 11N does disable N but doesn't remove my problems. –  James Green Jul 21 '11 at 14:51
    
Sorry...I have some issues with resume from suspend/resume from hibernate/or leaving the wireless card up for days. I don't have this symptom without a very specific scenario though. Hope you find something that works it out for you. Maybe changing power options? –  hbdgaf Jul 28 '11 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.