Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Trying GUI development with combination of Glade, FreeBasic and Geany, compilation fails because no gtkwidget.bi include file can be located. In fact this file is missing from my computer (Ubuntu Precise Pangolin)

share|improve this question

1 Answer 1

Did you install all of the dependancies with glade, freebasic and geany? If not then try and go to you software center and install al packages / dependancies that come with these pieces of software

If you try using this:

sudo aptitude install build-essential libc6-dev libncurses-dev libgpmg1-dev libx11-dev libxpm-dev libxrandr-dev libglitz-glx1-dev

just looked on internet for you and theres that ^ piece of code and also this link here :

FreeBasic installation video for Ubuntu

share|improve this answer
    
Thank you for your advice. Freebasic is missing from the software center. Uninstalled glade & geany (installed with apt-get installed) and reinstalled with ALL plugins. "gtk/gtkwidget.bi" is still missing. –  Laszlo Parkanyi Apr 20 '13 at 18:15
    
if you look at my previous answer i have just added some info for you try using the command thats there (you will need to go into terminal) you can also watch the video (the link provided) to help you out a little. –  DriftedMass Apr 20 '13 at 20:02
    
Thanks again. Tried the install command (I think you meant sudo apt-get install...). libglitz-glx1-dev is unavailable. The www.freebasic.net (as shown in the video) does not exist, only a sourceforge site, unfortunately there are only gzipped files and no references to headers, etc. I am giving up, will use Gambas instead of this complicated procedure. –  Laszlo Parkanyi Apr 22 '13 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.