Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running VirtualBox 4.1.18 on Ubuntu 12.10 host and running a Win XP SP3 guest I cannot rename or delete files once created.
Win guest complain with the error :

E:\ is not accessible
Incorrect function

Just the host can.
First of all, I wanna say clearly that I followed instructions :

  • Guest Addiction installed (3 times) in xp guest
  • ubuntu user added to vboxusers group
  • Specified the folder to share in VM settings both before and after running the xp guest
  • I tried also running Virtualbox as root, same error.

Furthermore, instead of sharing an NTFS partition, I even tried using a normal folder in ubuntu filesystem, owned by ubuntu user.
Same error.

The sharing always works, but the modify / deletions of files don't.
I read several forums on the web and a lot of people are reporting this as a bug for YEARS...is this possible ??
After new versions and releases still this is not working ?
Anybody had ever found a workaround for this ?

Please help...
TIA
Enrico

One other piece of information - if I double-click on the file to execute the default action (e.g., double-click on .txt opens file in notepad, double-click on .RDP runs RDP file), it works fine. It's only if I try to edit such files that I get the behavior.

Two things that are odd about this setup (to me):

1) if I browse directly from start/run to \vboxsrv\sharename, it opens \VBOXSVR\sharename (note the change in name - srv vs. SVR below):

Screenshot showing difference in share names

2) when I open it in this manner (as opposed to browsing to the assigned drive letter (e.g., double-clicking on the E: drive (in my case) under My Computer), as shown in image above, I can edit the files!

To reproduce on XP Guest:

  • Browse to a file on the shared folder (e.g., test.txt) - you must browse to the drive letter assigned to the share.

  • right-click and select Edit from the context menu.

share|improve this question
    
You tagged your question with "Samba" - how do you mount and access your shares? Related: askubuntu.com/questions/252853/… –  Takkat Apr 19 '13 at 9:20
    
I just wanna add that folders created by xp guest are saw by the host with 775 umask, and files as 664. Changing both to 777 doesn't solve the error. –  enrico Apr 19 '13 at 9:24
    
Thanks Takkat, but I'm using an XP guest from an ubuntu host... –  enrico Apr 19 '13 at 9:37
    
@enrico Why did you tag Samba? Samba transfers via network connection, while VirtualBox shared folders use file system drivers. They have nothing to do with each other. Samba is an alternative or workaround. –  ignis Apr 19 '13 at 14:18
    
Samba tag removed, but question still unanswered... –  enrico Apr 19 '13 at 17:12

1 Answer 1

Maybe something silly, but when I connected a hard drive I needed to set write permissions in the Virtual Machine settings.

share|improve this answer
    
Under Storage VM Settings you can only specify VIRTUAL Hard disks. For a real existing partion or folder you have to use the Shared Folder setting. –  enrico Apr 19 '13 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.