Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 on a Lenova ThinkPad. I updated a few days ago, and my wireless interface has basically disappeared. I can see where they should be when I click on my internet icon, but they're ghosted out.

I've tried the /etc/init.d/networking start and the 'service networking start' but I wasn't getting anywhere with either of them.

I found this question: Unable to connect to WiFi network after updates

and tried it out:

cordelia@bug:~$ rfkill list wlan

0: phy0: Wireless LAN                                                                
        Soft blocked: yes                                                             
        Hard blocked: yes
cordelia@bug:~$ rfkill unblock wlan
Can't open RFKILL control device: Permission denied
cordelia@bug:~$ sudo rfkill unblock wlan
cordelia@bug:~$ sudo service network-manager restart
network-manager stop/waiting                                                           
network-manager start/running, process 6814

That fixed his wireless, but I still can't get mine to work. And I really don't know why.

My ifconfig looks like this:

eth0                                                                                   
          Link encap:Ethernet  HWaddr 00:1f:16:0b:5b:b3                               
          inet6 addr: fe80::21f:16ff:fe0b:5bb3/64 Scope:Link                           
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                          
          RX packets:3892 errors:0 dropped:0 overruns:0 frame:0                        
          TX packets:4116 errors:0 dropped:0 overruns:0 carrier:0                       
          collisions:0 txqueuelen:1000                                                   
          RX bytes:3528991 (3.5 MB)  TX bytes:582490 (582.4 KB)                          
          Interrupt:20 Memory:f2600000-f2620000                                       

lo                                                                                  
          Link encap:Local Loopback                                                
          inet addr:127.0.0.1  Mask:255.0.0.0                                            
          inet6 addr: ::1/128 Scope:Host                                                
          UP LOOPBACK RUNNING  MTU:16436  Metric:1                                      
          RX packets:4835 errors:0 dropped:0 overruns:0 frame:0                         
          TX packets:4835 errors:0 dropped:0 overruns:0 carrier:0                       
          collisions:0 txqueuelen:0                                                     
          RX bytes:390732 (390.7 KB)  TX bytes:390732 (390.7 KB)                        

And my lspci:                                                                         
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

My dad poked around but couldn't find a solution. When I click on the wireless interface it gives me this list of data:

Type: Wireless 802.11
Connection State: Unavailable
IP Address: No IP address.
Connection Speed: Unknown
System Name: wlan0
MAC Address: 00:21:5D:91:28:DA
Driver: iwlwifi

I don't know what I'm doing wrong or not doing right. Is there anything else I need to try or tell you?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

"Hard blocked: yes" strongly suggests that the hardware switch and/or key combination, Fn+F5 on my Lenovo, is set to turn the wireless radio off. Please find the switch and turn the radio on. In some countries, including the USA, there is a key combination as well as a separate wireless slide switch.enter image description here

share|improve this answer
    
And that was it! Thank you so much, that was driving me crazy! –  Cordelia Apr 19 '13 at 15:49
    
Glad it's working! –  chili555 Apr 19 '13 at 18:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.