Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install these items and this is how it goes...

$ sudo apt-get install build-essential libssl-dev libdb5.1-dev libdb5.1++-dev libboost-all-dev git  
Reading package lists... Done  
Building dependency tree       
Reading state information... Done  
build-essential is already the newest version.

git is already the newest version.
The following extra packages will be installed:

  gccxml libboost-chrono-dev libboost-chrono1.49-dev libboost-chrono1.49.0  
  libboost-date-time-dev libboost-date-time1.49-dev libboost-dev  
  libboost-filesystem-dev libboost-filesystem1.49-dev  
  libboost-filesystem1.49.0 libboost-graph-dev libboost-graph-parallel-dev  
  libboost-graph-parallel1.49-dev libboost-graph-parallel1.49.0  
  libboost-graph1.49-dev libboost-graph1.49.0 libboost-iostreams-dev  
  libboost-iostreams1.49-dev libboost-locale-dev libboost-locale1.49-dev  
  libboost-locale1.49.0 libboost-math-dev libboost-math1.49-dev    
  libboost-math1.49.0 libboost-mpi-dev libboost-mpi-python-dev  
  libboost-mpi-python1.49-dev libboost-mpi-python1.49.0 libboost-mpi1.49-dev  
  libboost-mpi1.49.0 libboost-program-options-dev  
  libboost-program-options1.49-dev libboost-program-options1.49.0  
  libboost-python-dev libboost-python1.49-dev libboost-python1.49.0  
  libboost-random-dev libboost-random1.49-dev libboost-random1.49.0  
  libboost-regex-dev libboost-regex1.49-dev libboost-regex1.49.0  
  libboost-serialization-dev libboost-serialization1.49-dev  
  libboost-serialization1.49.0 libboost-signals-dev libboost-signals1.49-dev  
  libboost-signals1.49.0 libboost-system-dev libboost-system1.49-dev  
  libboost-system1.49.0 libboost-test-dev libboost-test1.49-dev  
  libboost-test1.49.0 libboost-thread-dev libboost-thread1.49-dev  
  libboost-thread1.49.0 libboost-timer-dev libboost-timer1.49-dev  
  libboost-timer1.49.0 libboost-wave-dev libboost-wave1.49-dev  
  libboost-wave1.49.0 libboost1.49-dev libdb5.1++ libexpat1-dev libibverbs-dev  
  libibverbs1 libicu-dev libopenmpi-dev libopenmpi1.3 libssl-doc libtorque2  
  mpi-default-dev openmpi-common python-dev python2.7-dev zlib1g-dev  

Suggested packages:

  libboost-doc graphviz libboost1.49-doc xsltproc doxygen docbook-xml
  docbook-xsl fop db5.1-doc icu-doc

The following NEW packages will be installed:

  gccxml libboost-all-dev libboost-chrono-dev libboost-chrono1.49-dev  
  libboost-chrono1.49.0 libboost-date-time-dev libboost-date-time1.49-dev  
  libboost-dev libboost-filesystem-dev libboost-filesystem1.49-dev  
  libboost-filesystem1.49.0 libboost-graph-dev libboost-graph-parallel-dev  
  libboost-graph-parallel1.49-dev libboost-graph-parallel1.49.0  
  libboost-graph1.49-dev libboost-graph1.49.0 libboost-iostreams-dev  
  libboost-iostreams1.49-dev libboost-locale-dev libboost-locale1.49-dev  
  libboost-locale1.49.0 libboost-math-dev libboost-math1.49-dev  
  libboost-math1.49.0 libboost-mpi-dev libboost-mpi-python-dev  
  libboost-mpi-python1.49-dev libboost-mpi-python1.49.0 libboost-mpi1.49-dev  
  libboost-mpi1.49.0 libboost-program-options-dev  
  libboost-program-options1.49-dev libboost-program-options1.49.0  
  libboost-python-dev libboost-python1.49-dev libboost-python1.49.0  
  libboost-random-dev libboost-random1.49-dev libboost-random1.49.0  
  libboost-regex-dev libboost-regex1.49-dev libboost-regex1.49.0  
  libboost-serialization-dev libboost-serialization1.49-dev  
  libboost-serialization1.49.0 libboost-signals-dev libboost-signals1.49-dev  
  libboost-signals1.49.0 libboost-system-dev libboost-system1.49-dev  
  libboost-system1.49.0 libboost-test-dev libboost-test1.49-dev  
  libboost-test1.49.0 libboost-thread-dev libboost-thread1.49-dev  
  libboost-thread1.49.0 libboost-timer-dev libboost-timer1.49-dev  
  libboost-timer1.49.0 libboost-wave-dev libboost-wave1.49-dev  
  libboost-wave1.49.0 libboost1.49-dev libdb5.1++ libdb5.1++-dev libdb5.1-dev  
  libexpat1-dev libibverbs-dev libibverbs1 libicu-dev libopenmpi-dev  
  libopenmpi1.3 libssl-dev libssl-doc libtorque2 mpi-default-dev  
  openmpi-common python-dev python2.7-dev zlib1g-dev  

0 upgraded, 82 newly installed, 0 to remove and 0 not upgraded.

Need to get 2,450 kB/65.1 MB of archives.

After this operation, 238 MB of additional disk space will be used.

Do you want to continue [Y/n]? y

Err http://us.archive.ubuntu.com/ubuntu/ quantal-updates/main libssl-dev i386 1.0.1c-3ubuntu2.2
  404  Not Found [IP: 91.189.91.13 80]

Err us.archive.ubuntu/ubuntu/ quantal-updates/main libssl-doc all 1.0.1c-3ubuntu2.2
  404  Not Found [IP: 91.189.91.13 80]

Failed to fetch us.archive.ubuntu/ubuntu/pool/main/o/openssl/libssl-dev_1.0.1c-3ubuntu2.2_i386.deb  404  Not Found [IP: 91.189.91.13 80]

Failed to fetch http://us.archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl-doc_1.0.1c-3ubuntu2.2_all.deb  404  Not Found [IP: 91.189.91.13 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

[NOTE]took out the http's, .com's and .net's to comply with the post.

So then I run the sudo apt-get update

$ sudo apt-get update  
Hit us.archive.ubuntu quantal Release.gpg
Get:1 us.archive.ubuntu quantal-updates Release.gpg [933 B]         
Get:2 us.archive.ubuntu quantal-backports Release.gpg [933 B]       
Get:3 www.lamaresh squeeze Release.gpg [1,270 B]                    
Get:4 extras.ubuntu quantal Release.gpg [72 B]                      
Get:5 ppa.launchpad quantal Release.gpg [316 B]                     
Get:6 security.ubuntu quantal-security Release.gpg [933 B]          
Hit us.archive.ubuntu quantal Release                               
Get:7 us.archive.ubuntu quantal-updates Release [49.6 kB]           
Hit extras.ubuntu quantal Release                                   
Hit ppa.launchpad quantal Release                                   
Get:8 security.ubuntu quantal-security Release [49.6 kB]            
Get:9 www.lamaresh squeeze Release [1,265 B]                        
Hit us.archive.ubuntu quantal-backports Release                     
Ign www.lamaresh squeeze Release                                    
E: GPG error: www.lamaresh squeeze Release: The following signatures were invalid: NODATA 1 NODATA 2

[NOTE]took out the http's, .com's and .net's to comply with the post.

Followed by:
$ sudo apt-get upgrade  
Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

so nothing worked...really puzzled any ideas?

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.