Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a laptop that I would like to install ubuntu on. This laptop has windows xp on it, but windows wont load. I have ubuntu loaded onto a usb drive, but the computer I am trying to install it on will not recognize the usb drive in the BIOS menu.

share|improve this question
Do you mind adding more information? Like, the kind of Laptop you have? What version of Ubuntu you're installing and how you went about obtaining the live-usb? What do you mean Windows wont load? Is there an issue with Windows or is it hardware related? – Nil Apr 19 '13 at 1:51
I appreciate the quick reply. The laptop is an old emachines with an AMD athlon processor. The version of ubuntu is 12.04.What do you mean "obtaining the live-usb"? And as far as Windows, When I start up the laptop, after the loading screen for window, a blue creen comes up and says Unmountable boot volume. – user150466 Apr 19 '13 at 1:57
Reason I was asking about the laptop was to see if I could find information on the BIOS settings. Also, how did you load Ubuntu onto the usb drive? And any relevant information you want to add should be put into the body of the question using the edit button. Lastly, I was asking about your Windows distribution because I thought there may have been anissue with the harddrive. But if the windows logo is showing, I doubt that its an hardware issue. – Nil Apr 19 '13 at 2:03
I should point out that some BIOS don't support booting from usbs... – Nil Apr 19 '13 at 2:05
Ahhh. Ill add the info into the body. And I followed all of the instructions on the website to get it onto the usb drive. Ive gone into the BIOS menu, and It says "boot from removable device". Would that not be USB? – user150466 Apr 19 '13 at 2:07

you may enter the bios and chose the boot device and then save the bios setting and reboot.Though you do not really need to change the boot priority.In fact my samsung laptop always come across this phenomena,it's my solution.It seems that by entering the bios and pretending to change and save the bios setting can make the computer recognizing the usb device.

share|improve this answer

Ran into same problem, answer was that you have to go into the BIOs option about Hard Disks. In mine it saw the USB as a second HDD so I had to change the priority so it would read the USB "Hard Disk" first instead of the actual HDD which it did by default.

share|improve this answer
The OP stated that the BIOS menu does't recognize the USB. So changing the boot order won't help... – the_Seppi May 16 '15 at 11:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.