Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh install of 12.04 ran the updates just fine. (I hate not having my synaptic package manager) I went to fetch k9copy and this is what I got. Package uudeview is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

I went to the website and downloaded the .deb but after I dpkg -i blah.deb I’m not sure what to do from there. But, I get this error also when trying to fetch the different media codecs and such. Here is it all failing at once but the wall papers it looks like.

$ sudo apt-get --yes --quiet --allow-unauthenticated install medibuntu-keyring
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  medibuntu-keyring
0 upgraded, 1 newly installed, 0 to remove and 32 not upgraded.
Need to get 3,448 B of archives.
After this operation, 49.2 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  medibuntu-keyring
Authentication warning overridden.
Get:1 http://packages.medibuntu.org/ precise/free medibuntu-keyring all 2008.04.20 [3,448 B]
Fetched 3,448 B in 0s (11.2 kB/s)
Selecting previously unselected package medibuntu-keyring.
(Reading database ... 141467 files and directories currently installed.)
Unpacking medibuntu-keyring (from .../medibuntu-keyring_2008.04.20_all.deb) ...
Setting up medibuntu-keyring (2008.04.20) ...
OK
customer@customer-VGC-RB40:~$ sudo apt-get install firestarter synaptic ubuntu-tweak vlc gimp gimp-data gimp-plugin-registry gimp-data-extras openshot openshot-doc transmission-gtk transmission-common y-ppa-manager skype bleachbit indicator-ubuntuone lo-menubar libxss1 libnss3-1d openjdk-7-jre unace unrar zip unzip p7zip-full p7zip-rar sharutils rar uudeview mpack lha arj cabextract file-roller non-free-codecs libxine1-ffmpeg gxine mencoder flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-dev mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg totem-mozilla icedax tagtool easytag id3tool lame nautilus-actions-extra nautilus-script-audio-convert libmad0 libjpeg-progs libdvdcss2 w32codecs libavcodec53 libavutil51 ubuntu-restricted-extras app-install-data-medibuntu apport-hooks-medibuntu ubuntu-wallpapers*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'ubuntu-wallpapers-lucid' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers-maverick' for regex 'ubuntu-wallpapers*'
Note, selecting 'edubuntu-wallpapers' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers-precise' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers-extra' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers-oneiric' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers-karmic' for regex 'ubuntu-wallpapers*'
Note, selecting 'ubuntu-wallpapers-natty' for regex 'ubuntu-wallpapers*'
Note, selecting 'blubuntu-wallpapers' for regex 'ubuntu-wallpapers*'
Note, selecting 'xubuntu-wallpapers' for regex 'ubuntu-wallpapers*'
Package libxine1-ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package arj is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package cabextract is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package synaptic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package p7zip-full is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package icedax is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package sox is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package unace is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package gimp-data-extras is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package lame is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libmpeg2-4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package easytag is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package bleachbit is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package faad is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package ffmpeg2theora is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package firestarter is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package gimp-plugin-registry is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package gxine is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package id3tool is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package id3v2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libmpeg3-1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package lo-menubar is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpack is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpeg2dec is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpeg3-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpegdemux is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpg123 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpg321 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package nautilus-script-audio-convert is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package openshot is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package openshot-doc is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package tagtool is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package uudeview is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'firestarter' has no installation candidate
E: Package 'synaptic' has no installation candidate
E: Package 'gimp-plugin-registry' has no installation candidate
E: Package 'gimp-data-extras' has no installation candidate
E: Package 'openshot' has no installation candidate
E: Package 'openshot-doc' has no installation candidate
E: Unable to locate package skype
E: Package 'bleachbit' has no installation candidate
E: Package 'lo-menubar' has no installation candidate
E: Package 'unace' has no installation candidate
E: Package 'p7zip-full' has no installation candidate
E: Package 'uudeview' has no installation candidate
E: Package 'mpack' has no installation candidate
E: Package 'arj' has no installation candidate
E: Package 'cabextract' has no installation candidate
E: Package 'libxine1-ffmpeg' has no installation candidate
E: Package 'gxine' has no installation candidate
E: Package 'faad' has no installation candidate
E: Package 'sox' has no installation candidate
E: Package 'ffmpeg2theora' has no installation candidate
E: Package 'libmpeg2-4' has no installation candidate
E: Package 'uudeview' has no installation candidate
E: Package 'libmpeg3-1' has no installation candidate
E: Package 'mpeg3-utils' has no installation candidate
E: Package 'mpegdemux' has no installation candidate
E: Unable to locate package liba52-dev
E: Package 'mpeg2dec' has no installation candidate
E: Package 'id3v2' has no installation candidate
E: Package 'mpg321' has no installation candidate
E: Package 'mpg123' has no installation candidate
E: Package 'icedax' has no installation candidate
E: Package 'tagtool' has no installation candidate
E: Package 'easytag' has no installation candidate
E: Package 'id3tool' has no installation candidate
E: Package 'lame' has no installation candidate
E: Package 'nautilus-script-audio-convert' has no installation candidate
customer@customer-VGC-RB40:~$ sudo apt-get install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 32 not upgraded.
customer@customer-VGC-RB40:~$ non-free-codecs libxine1-ffmpeg gxine mencoder flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-dev mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libdvdcss2 w32codecs libavcodec53 libavutil51 ubuntu-restricted-extras app-install-data-medibuntu apport-hooks-medibuntu
non-free-codecs: command not found
customer@customer-VGC-RB40:~$ sudo apt-get non-free-codecs libxine1-ffmpeg gxine mencoder flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-dev mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libdvdcss2 w32codecs libavcodec53 libavutil51 ubuntu-restricted-extras app-install-data-medibuntu apport-hooks-medibuntu
E: Invalid operation non-free-codecs
customer@customer-VGC-RB40:~$ sudo apt-get install non-free-codecs libxine1-ffmpeg gxine mencoder flac faac faad sox ffmpeg2theora libmpeg2-4 uudeview libmpeg3-1 mpeg3-utils mpegdemux liba52-dev mpeg2dec vorbis-tools id3v2 mpg321 mpg123 libflac++6 ffmpeg totem-mozilla icedax tagtool easytag id3tool lame nautilus-script-audio-convert libmad0 libjpeg-progs libdvdcss2 w32codecs libavcodec53 libavutil51 ubuntu-restricted-extras app-install-data-medibuntu apport-hooks-medibuntu
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libxine1-ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package icedax is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package sox is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package lame is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libmpeg2-4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package easytag is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package faad is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package ffmpeg2theora is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package gxine is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package id3tool is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package id3v2 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package libmpeg3-1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpeg2dec is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpeg3-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpegdemux is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpg123 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package mpg321 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package nautilus-script-audio-convert is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package tagtool is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package uudeview is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libxine1-ffmpeg' has no installation candidate
E: Package 'gxine' has no installation candidate
E: Package 'faad' has no installation candidate
E: Package 'sox' has no installation candidate
E: Package 'ffmpeg2theora' has no installation candidate
E: Package 'libmpeg2-4' has no installation candidate
E: Package 'uudeview' has no installation candidate
E: Package 'libmpeg3-1' has no installation candidate
E: Package 'mpeg3-utils' has no installation candidate
E: Package 'mpegdemux' has no installation candidate
E: Unable to locate package liba52-dev
E: Package 'mpeg2dec' has no installation candidate
E: Package 'id3v2' has no installation candidate
E: Package 'mpg321' has no installation candidate
E: Package 'mpg123' has no installation candidate
E: Package 'icedax' has no installation candidate
E: Package 'tagtool' has no installation candidate
E: Package 'easytag' has no installation candidate
E: Package 'id3tool' has no installation candidate
E: Package 'lame' has no installation candidate
E: Package 'nautilus-script-audio-convert' has no installation candidate
share|improve this question
    
What happens if you try to install packages one at a time? –  Elder Geek Jun 24 at 0:13
    
Medibuntu is no more. –  chaskes Jun 24 at 3:34

1 Answer 1

First go into software sources and insure the main repository is checked.

software sources

Then try:

sudo apt-get update

sudo apt-get install build-essential

sudo dpkg --configure -a

sudo apt-get -f install

then try to install the rest.

Source: http://musingsonsoftware.blogspot.com/2014/02/ubuntu-apt-get-package-has-no.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.