Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I manage a private network which has no internet connectivity due to the security policy of the customer. This network has a single Ubuntu 10.04 LTS Server installation (soon to be several more) and I've been trying to customise it with software - however, I'm having to manually install packages with dpkg because of the lack of internet connectivity.

Does this prevent me from upgrading to a newer version of Ubuntu Server (LTS) when it becomes available, since the packags I've installed aren't ont he current distribution CD, they're unlikely to be on the newer releases also.

share|improve this question
3  
Side note: Since there are several more Ubuntu servers to come, perhaps you might want to consider a local repository? –  andol Jul 29 '10 at 6:25
3  
Why is this community wiki? –  Nathan Osman Jul 29 '10 at 7:55
    
@George Edison - why not? –  James Booker Sep 3 '10 at 11:50
1  
@James: Because nobody gains rep. from CW questions. –  Nathan Osman Sep 3 '10 at 20:27

4 Answers 4

up vote 15 down vote accepted

No. Installing packages from the official repositories using dpkg will not give you any problems down the road.

In fact, from a technical point of view, installing a package via dpkg is no different than if you had run sudo apt-get install package. The same things happen.

The only problem with installing packages with dpkg is that you will have to make sure that the dependencies are installed in the right order. If not, you could wind up with a corrupted package database.

I know this happens from personal experience...

share|improve this answer
    
What do you mean by installed in the right order? If a lib has 3 dependencies, a, b and c, then they would need to be installed in a specific order? Why? –  levesque Jul 29 '10 at 14:25
    
@JCL: Because some of the dependencies are likely dependent on each other. –  Nathan Osman Jul 29 '10 at 16:14
1  
The package database would not be corrupted... but it would indicate that a package is only unpacked (and not configured) because of missing dependencies. Corrupted would mean broken and that dpkg would no longer work. In the case you mention, it does still work and you can complete the installation by using dpkg to install the missing dependencies (or even apt-get -f install). –  Raphaël Hertzog Aug 12 '10 at 7:58
    
@Rap: Yes, it would. That has actually happened to me. And yes, dpkg did not work after. –  Nathan Osman Aug 12 '10 at 19:18
1  
I'm afraid the problem you had was unrelated to the specific operations that you describe. Something else must have happened. Unexpected power failure, filesystem corruption or whatever but installing packages in the bad order does not corrupt the dpkg database. I am a dpkg maintainer and we would have seen lots of related bugreports if that was really the case. –  Raphaël Hertzog Aug 19 '10 at 16:37

It might be a better idea, considering you'll be adding more servers soon, to set up a local repository. This way, you can add the repo to the apt sources of each server and then point them all to a local repository that is just a mirror of the real ubuntu repos.

Then when it is time to install or upgrade packages, you just use the standard ubuntu tools to handle this operation. Another benefit is that you just have to update the centralized local repo every once in a while with a couple of DVDs or hard drive that you can bring into the closed environment and sync with the repo's directories. Then each server will alert you to the packages that they have installed that have upgrades available on your local repo... meaning you have a lot less administrivia to maintain. The tools are allowed to do what the tools are good at.

Alan Pope, ubuntu evangelist and one of the team behind the Ubuntu UK podcast, wrote a post on creating a mirror of the official ubuntu repositories that should help. You can find it here.

share|improve this answer

AptOnCD might be a useful tool for you in this case: http://aptoncd.sourceforge.net/

share|improve this answer

Just for completeness: when you upgrade, if your packages are not supported anymore, or incompatible with newer packages (broken dependencies, etc), then the upgrade process will ask you if you want to remove those packages. I'm not sure what happens if you don't uninstall them - probably they will not work anymore.

In any case, you will be able to upgrade.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.