Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First of all, thanks for your time.

I see that every time this question was asked, the thread was closed before it got an answer. so please, can you at least point me in that right direction?

When going to the boot menu (after pressing option), the powerbook G4 667mhz detects the installer (either on a CD or flashdrive - depending on what I am using) but when I choose the Linux installer the screen flashes and the menu comes back in low resolution. Only the mouse works.

I suspect the firmware is looking for a very specific configuration in the disc and it is not finding it. the same problem happens if i try to boot up the Leopard (OSX 10.5) installer or DiskWarrior 4. But Diskwarrior 3.3 and the Tiger (OSX 10.4) installer boot up without a problem.

It is not the Ubuntu installer because it works fine on an iMac. maybe there is a way to work on yaboot or GRUB to talk the the Tibook? Any ideas?


The processor is: PowerPC 7440 G4

in system profiler i get:

Processor name: PowerPC G4 (2.1)
Boot ROM version: 4.2.9f1

The installer is for powerpc, and it works fine in my iMac (another powerPC G4). it seems to be something more specific. I have tried different distros (yellow dog, Lubuntu, Debian) and they all have the same problem with this computer but not with the iMac.


Like I thought, it has to do with yaboot. I restored the image of the installer in another partition of the hard drive and forced the boot from the firmware. yaboot starts and flashes these lines:

loading XCOFF

tsize=28000 dsize=2000 bsize=3a000 entry=5616ecc
SECTIONS
.text     05600000   05600000   00028000 000000d4
.data     05628000   05628000   00002000 000280d4
.bss      0562a000   0562a000   0003a000 00000000
loading .tex,  done
loading  .data, done
clearing .bss, done

after which it shows the "forbidden/not allowed/cross out circle sign" that indicates that the operating system is in a broken folder or corrupted ( I think, I haven't seen that symbol in a while)

share|improve this question
add comment

2 Answers

I think powerpc's have a separate port of ubuntu. This is a quote:

Desktop CD

The desktop CD allows you to try Ubuntu without changing your computer at all, and at your option to install it permanently later. You will need at least 384MiB of RAM to install from this CD.

There is one image available:

Mac (PowerPC) and IBM-PPC (POWER5) desktop CD

For Apple Macintosh G3, G4, and G5 computers, including iBooks and PowerBooks as well as IBM OpenPower machines.

EDIT: This answer may prove to be relevant. I'm pretty sure that the port of Ubuntu you're trying to use wont work. As far as I know, there isn't a desktop edition of 12.10 available yet for powerpc's. There is a server edition, and, if you follow the above links, desktop editions of 12.04

share|improve this answer
add comment

The problem is due to the way Open Firmware (in the version installed in these powerbooks) maps the devices.

In order to boot from the CD, you should try going into Open Firmware (reboot computer and press Option-Command-o-f ).

at the prompt, try typing:

boot ide1:2,\install\yaboot

the cd is mapped as ide1 and for some reason it needs to look for the 3rd partition of the CD (didn't you know there was more than one partition in the cd?? Neither did I!!!). that is why you should try to boot from ide1:2

if your powerbook is like mine, you should reach the yaboot prompt (from the CD) with that command, but the installer may not run due to the fact that the screen size is not standard (these laptops use the Ati Radeon video chip but the screen is 1152 x 768) and the framebuffer is not configured by default. I found many suggestions online but failed with all of them.

But there is a workaround: connect an external monitor and try to work from within the system.

I managed to install Lubuntu 10.04 with an external monitor and simply adding: Nosplash video=ofonly to the main command (either Linux or Install).

an even better solution: install Debian instead. at least Debian 6 can be installed from yaboot with:

install32 nosplash video=ofonly

Debian doesn't need the external monitor since it configures the screen right away.

share|improve this answer
add comment

protected by Community Jul 5 '13 at 20:24

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.