Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having problems connecting my Buffalo external 500GB hard disk in Ubuntu 12.04 LTS. The HDD is password protected and when I connect it on my PC, it just shows up the CD icon on the launcher. It works perfectly with Windows XP and Windows 7. Ii is preloaded with the password software - Utility_HD-PXTU, so whenever I connect it it first asks for the password. But in Ubuntu it is showing

unable to mount Utility_HD-PXTU
Error mounting: mount: /dev/sr2 already mounted or /media/Utility_HD-PXTU busy

and when I click on the CD icon it open a folder with some files on it

Error mounting: mount: block device /dev/sr2 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr2,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
share|improve this question
    
Does it need a Windows program to enter the password? How did you password protect the drive? If you used some software that came with it, it is probably a Windows program. What happens when you click on the CD icon? Please add more information by editing your original question. –  user68186 Apr 18 '13 at 14:24
2  
Connect the drive to Windows, remove the password, and try connecting to Ubuntu. –  Mitch Apr 18 '13 at 14:39
    
now it is showing more details in the error please look into it –  gurmeet Apr 18 '13 at 14:42
    
I'm fairly sure this drive just uses the ATA security specifications. With the right hdparm/sdparm commands you could unlock it, I think. However, I don't own such a hard drive, so this is mostly just guessing. –  gertvdijk Aug 22 '13 at 15:39

2 Answers 2

up vote 1 down vote accepted

From what I could gather from the Internet, Buffalo uses proprietary software that runs on Windows to encrypt the hard drive. It won't work with Ubuntu or any non-windows operating system.

As @mitch says in comments you have to remove the password and encryption using Buffalo's Secure Lock Manager. An unencrypted drive will work in both Windows and Ubuntu.

If you want to encrypt some files that you will only use in Windows, see Secure Lock Manager documentation on how to encrypt a part of the hard drive. This part will not be available to Ubuntu, but at least you will be able to use a part of the hard drive in Ubuntu.

Hope this helps

share|improve this answer
    
thanks for the help, I wish it help me. –  gurmeet Apr 18 '13 at 14:54
    
@gurmeet You are welcome. If you think this answer is correct, please accept it as the correct answer and put a green tick mark next to it. This will help others who may have the similar problems later. –  user68186 Apr 18 '13 at 14:57

I had similar problem with WD HDD. WD Software does not work on Linux. What I did: I removed password and I access it normally from Windows as well from Linux. However now you need to encrypt files that are stored on external drive: I suggest using 7z. In manual you have example how to do it: On Linux/Unix, in order to backup directories you must use tar : - to backup a directory :

tar cf - directory | 7za a -si directory.tar.7z

You just need to add -p flag to make it password protected. I hope it will give you some clues how to proceed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.