Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, I tried installing Ubuntu 12.10 and when installing I went to click on Something Else to install to a pre-made partition but when I clicked on continue I realised I either missed (don't laugh) or the mouse didn't click properly but it went straight to formatting and trying to do a complete install. Luckily just as it started formatting there was an error and in my panic I didn't think to write it down. After exiting the installer I checked to see if my windows partition was still ok, thankfully it was and I could still see and access everything. I then re-started my laptop to try and boot back into windows 8.

No dice, I get the error Media Check [Fail] and I can now only boot up using Live Ubuntu, I tried installing Ubunutu on a seperate 8.5GB partition I had but no dice there either.

Tried using Boot-Repair and that failed as well but here is the Info Summary for it http://paste.ubuntu.com/5717818/

Is it possible to fix without using a Windows recovery disk? I just have to hunt around for one is all. Also it would be good to keep my files but it's not absolutely necessary.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

My short recommendation: Do a complete low-level backup of your disk, and then dig up a Windows 8 recovery disc and use it on the original disk.

The long story: I see at least three things wrong with your current setup:

  • Your /dev/sda2, which might once have been Windows, is identified as as "unknown filesystem" by the Boot Repair tool. This is Bad News, since this tool can normally identify the NTFS that's used by Windows. Maybe a Windows tool can repair the damage, but maybe not; and it's very unlikely that you'll get anywhere attempting to repair it in Linux.
  • Your EFI boot order is "0003,2001", but there's no obvious Windows boot entry. Boot entry 0003 is for Ubuntu (GRUB), and 2001 is for a USB flash drive. Thus, your computer will attempt to boot GRUB when it starts.
  • Your GRUB configuration includes no entry for Windows, so in conjunction with the previous item, even if your Windows volume could be read, you wouldn't be able to boot Windows. In theory, you could add a Windows entry to GRUB, but I'm doubtful that it would work, given the probable filesystem damage to /dev/sda2.

The first of these points is the most critical: Repairing NTFS is something that Linux just can't do. Thus, sooner or later you'll need to fire up a Windows repair tool, and it might as well be sooner rather than later. Attempting to put this off might yield results, but is more likely to be a waste of time; and even if it works, the results of getting the current Windows installation to boot and repair itself are not likely to be any better than the results you'd get from running a Windows repair disc.

Try checking with Microsoft to find such a disc. I've heard that they exist and are fairly easy to find, but I don't happen to have any URLs handy.

share|improve this answer
    
Thanks for your answer, I tried using Windows repair tool, no luck. After investigating and digging around for quite a while I decided the damage to the file system was too extensive to repair and chose to just do a complete format and re-install as I couldn't afford the time to go digging around for another few days. –  Michael Apr 22 '13 at 1:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.