Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The simple keyboard combination of Alt-Tab to switch between applications doesn't work.

I have followed this answer but it doesn't answer the question as I want to switch to another application, not display applications and then have to select it via the mouse as it defeats the purpose of the quick switch to the other application.

There is also mention of updating the Keyboard shortcut settings. My keyboard combination is set to the Alt-Tab in the shortcut section and it doesn't switch applications. Seems the setting is ignored as I changed it to another keyboard combo and it just doesn't switch applications.

share|improve this question
    
Are you using "gnome classic no effects"? –  Seth Apr 18 '13 at 14:30
    
@seth No, just Gnome Classic –  Meer Borg Apr 18 '13 at 22:43
add comment

2 Answers 2

up vote 8 down vote accepted

Seems Application Switching is turned of by default.

To activate it you need to run the following command

ccsm

That will bring up CompizConfig Settings Manager.

  • Go to the Window Management section.
  • Check off ✔ Application Switcher.

Then the Alt+Tab will work.

Require installation of the compiz-plugins-extra package.

share|improve this answer
add comment

The solution in Meer Borg's answer made my computer very slow.

I instead checked the:

✔ Static Application Switcher

That also solves this problem.

share|improve this answer
    
yeahh this thing worked for me too –  Tejas Ghalsasi May 29 at 9:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.