Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to connect to a device over link-local via IPv4. I've done my best to configure the GigE port correctly.

enter image description here

  • When I turn the device on, the Ubuntu (12.10) gui pops up an icon saying I'm connected to the device.

Connection

  • ifconfig shows the following for eth1:

    Link encap:Ethernet  HWaddr 60:a4:4c:22:17:08  
    inet addr:169.254.148.88  Bcast:169.254.255.255  Mask:255.255.0.0
    UP BROADCAST RUNNING MULTICAST  MTU:100  Metric:1
    RX packets:559 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2033 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000 
    RX bytes:193414 (193.4 KB)  TX bytes:203089 (203.0 KB)
    Interrupt:18 Memory:f7900000-f7920000 
    

I have vendor supplied software that will automatically recognize the device when I run it. Without going into the details, it is basically just a C++ executable that is meant to demo the provided SDK by finding a device and working with it. I don't think it is a problem with the code. The SDK is made for linux, but their tech help is pretty inexperienced with Ubuntu and thinks its just a problem with how I am setting up the connection.

  • Furthermore, I have connected this device to the same machine, same GigE port, while booted into Windows, and it is recognized instantly. The connection is shown here:

enter image description here

I took the netmask and ip address from Windows and used ifonfig eth1 $IP netmask $netmask to get them to match. I don't much like this method, as eventually this will have to work on a computer without an Ubuntu GUI or a Windows partition.

  • When I tail the dmesg logs, I see that the connection is detected, but I get this message:

    [ 4174.533981] e1000e: eth1 NIC Link is Down
    [ 4180.212770] e1000e: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
    [ 4180.216769] netlink: 12 bytes leftover after parsing attributes.
    [ 4180.216772] netlink: 12 bytes leftover after parsing attributes.
    [ 4180.216929] netlink: 12 bytes leftover after parsing attributes.
    

I am fairly new to Linux, and very new to networking. But I've been banging my head against this problem and making no headway. Does anyone know anything about link-local, or the attribute parsing error that could give me some suggestions?

share|improve this question
    
What do you mean by this But my software cannot recognize it. The software is vendor supplied, as well as my own.? Could you give some details about the device & software you are talking about? –  Stef K Apr 17 '13 at 22:48
    
I edited the question, hopefully it is more clear. –  zachd1_618 Apr 17 '13 at 23:29
    
What is the IP address and netmask you use in Windows? What is the IP address of the device? –  psusi Apr 18 '13 at 0:33
3  
You can't connect to a device when you configure the interface for local--that is for local (the device itself, and no others, also known as 127.0.0.1, or the loopback) testing purposes only. To connect to the device, use a static or DHCP assigned address. –  RGS Jun 16 '13 at 13:38
1  
I think their pretty inexperienced tech is correct, thinking that the 'pretty inexperienced' customer isn't configuring the connection correctly ;) –  Marcin Kaminski Dec 4 '13 at 19:50

2 Answers 2

It appears your network settings are mis-configured. RGS's comment is correct: by selecting a local link, you are ensuring a network connection will not work. The IP address you've displayed that automatically works, is in the APIPA range. This is not the drone you seek...I mean connection.
http://packetlife.net/blog/2008/sep/24/169-254-0-0-addresses-explained/

All you should need to do for a wired connection is plug it into the computer; Ubuntu does the rest. https://help.ubuntu.com/12.10/ubuntu-help/net-wired-connect.html

If you are trying to connect 2 computers directly to each other, I would recommend assigning a "static IP address" to the Ubuntu machine: https://help.ubuntu.com/12.10/ubuntu-help/net-manual.html
In that case, give the Ubuntu Machine the following settings:

IP Address: 169.254.146.89
Subnet Mask: 255.255.0.0
Default Gateway: 169.254.146.88 (or whatever it says for IP Address in the window of that print screen you posted, the point being for it to find the windows machine by it's IP Address)

To access your network settings:

1. From the Dash Home (Ubuntu start menu, also accessed by hitting the windows key)
   type network and hit Enter.
2. Select Wired/Wireless and turn it On.

You listed some very detailed information, which is good. You did not give enough basic information though, such as:

1. How you are connecting: via a router, switch, modem, or directly to another computer.
2. Your desired network setup: DHCP, static, APIPA.
3. How many and what kind of devices you want to connect.

Ubuntu has some documentation aimed at walking you through setup. Please read that before posting a question in the future. https://help.ubuntu.com/12.10/ubuntu-help/index.html

share|improve this answer

If you connect two PC directly nic to nic you must have a crossover cable.

share|improve this answer
4  
Crossover cables are not needed with most 1000BASE-T devices, as Automatic MDI/MDI-X is widely implemented. Besides: the output of dmesg in the question indicates that a hardware link has been established successfully. –  Adaephon Feb 28 at 13:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.