Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am struggling with no sound problem on Ubuntu 12.04 and now on 12.10. I went through a lot of forums mentioning this issue and I have tried a lot of different solutions that worked for others but not for me. There is no sound from speakers unless I do

sudo aptitude reinstall alsa-utils

After reboot everything is working fine but after another reboot there is no sound again. So if I wanted to have the audio output on the next boot I have to reinstall alsa-utils before shutting down the system :)

I have tried to install alsa-utils not from repository but from the developers site but it did not help, do you have an idea where could be the problem and why the sound works only for the first time the system is on?

If it helps here is output from aplay -l:

**** Seznam PLAYBACK Hardwarových zařízení ****

+ karta 0: Intel [HDA Intel], zařízení 0: ALC271X Analog [ALC271X Analog]
  Podzařízení: 1/1
  Podzařízení #0: subdevice #0

+ karta 0: Intel [HDA Intel], zařízení 1: ALC271X Digital [ALC271X Digital]
  Podzařízení: 1/1
  Podzařízení #0: subdevice #0
share|improve this question
    
Does "no sound" mean that programs appear to play something, but nothing comes out of the speakers? Could you check if mixer controls get changed? –  CL. Apr 18 '13 at 11:15
    
well I have always tried it on youtube videos where the video is playing but there is no sound. So right now I am trying to open some .avi file but it hangs and there is no screen, no sound, just no response. Even typing aplay -l has no result and it just hangs –  skornos Apr 18 '13 at 12:23
add comment

1 Answer 1

up vote 1 down vote accepted

Well for anyone who has the same problem I have found the solution. I purged the alsa driver and pulseaudio and did CLEAN install not from repository but from source provided on alsa website. It was followed by many many other errors like non-existing functions - fw_device_get and put which I have found on the Internet and put them into Linux kernel headers, included asm/system.h file which wasn't found (it was enough just to comment the line) and some others but now my sound works, we will see for how long :)

Also I sticked to this tutorial if it helps: ubuntuforums

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.