Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a SSL Certificate issued by GoDaddy. I already have a website up for ecommerce, and need to secure it.

I have tried everything to configure apache2, and install the SSL, but I cannot do it! Its stumping me!

One thing I tried was:

I have enabled SSL in Apache. I have generated a CSR, and got a GoDaddybundle.CRT and a CRT for the site. I have tried placing them in the SSL files in my Apache folder. I have to be honest....I am a serious Novice when it comes to this. I have never dealt with SSL.

share|improve this question
    
"Everything" is not very clear: explain what you tried and how it failed. Edit your question to give that information. –  guntbert Apr 17 '13 at 19:29
    
The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself. –  guntbert Apr 17 '13 at 20:26

1 Answer 1

1) Stop freaking out :)

2) Do you have mod_ssl installed?

3) Do you have mod_ssl enabled in apache? (enable it through a2enmod or create symlink in modules-enabled pointing to mod_ssl in modules-available)

4) with mod_ssl there usually comes sample configuration file, the basically-configured virtual host could look like this

<VirtualHost hostname:443>
DocumentRoot /var/www/html
ServerName hostname
SSLEngine on
SSLCertificateFile /path/to/certificate.crt
SSLCertificateKeyFile /path/to/private_key.key
SSLCertificateChainFile /path/to/certificate_chain_file.crt //this isnt really necessarry, quite useful though
</VirtualHost>

For future posts: please give more useful information than "it doesn't work".

share|improve this answer
    
Hahaha. Sorry! Let me check! –  Darren D. Apr 17 '13 at 19:41
    
In my terminal, I go to enable SSL, and it says that its enabled. I see that there are SSL files in my Apache File. –  Darren D. Apr 17 '13 at 19:56
1  
Now check if there are the symlinks I mentioned previously (there should be like three of them - for module and for configuration) really exist. Then just update the configuration of your site with the directives written in the snippet. If your private key is encrypted (you have to write password each time you use it) the the apache will ask you for the password when starting. –  Fiisch Apr 17 '13 at 20:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.