Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get XFApplet to work in my XFCE4 install for Ubuntu 12.04. I have tried installing it from the repos. But there is no xfapplet in apt-cache, instead I get this:

$ apt-cache search xfapplet
xfce4-goodies - enhancements for the Xfce4 Desktop Environment

So I make sure that xfce4 goodies is installed, which it is:

$ sudo apt-get install xfce4-goodies
Reading package lists... Done
Building dependency tree       
Reading state information... Done
xfce4-goodies is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 64 not upgraded.

Ok, so I go into the panel to add a new item and of course it's not there:

enter image description here

For the record I have GNOME installed completely! This is an Ubuntu system not Xubuntu, when I upgraded from 11 to 12.04 I wanted XFCE instead of Gnome, but I never uninstalled gnome at all. I can even run Gnome classic without any problems and all works, so that should mean all dependencies are there.

So then I decided to compile from source: (link at bottom) http://goodies.xfce.org/projects/panel-plugins/xfce4-xfapplet-plugin

Ok, so on configure I get this:

checking for libpanelapplet-2.0 >= 2.0.0... not found
*** The required package libpanelapplet-2.0 was not found on your system.
*** Please install libpanelapplet-2.0 (atleast version 2.0.0) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

Of course running apt-cache libpanelapplet I get nothing, but if I run apt-cache libpanel I get:

$ apt-cache search libpanel
gir1.2-panelapplet-4.0 - GObject introspection for the GNOME Panel Applet library
gnome-panel-dbg - GNOME Panel and library for panel applets - debugging symbols
libpanel-applet-4-0 - library for GNOME Panel applets
libpanel-applet-4-dev - library for GNOME Panel applets - development files
libpanel-applet-4-doc - library for GNOME Panel applets - documentation files

So I install 4:

$ sudo apt-get install libpanel-applet-4-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libgconf2-dev libgconf2-doc libpanel-applet-4-doc
The following NEW packages will be installed:
  libgconf2-dev libgconf2-doc libpanel-applet-4-dev libpanel-applet-4-doc
0 upgraded, 4 newly installed, 0 to remove and 64 not upgraded.
Need to get 326 kB of archives.
After this operation, 2,906 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://gt.archive.ubuntu.com/ubuntu/ precise/main libgconf2-dev i386 3.2.5-0ubuntu2 [118 kB]
Get:2 http://gt.archive.ubuntu.com/ubuntu/ precise/main libgconf2-doc all 3.2.5-0ubuntu2 [101 kB]
Get:3 http://gt.archive.ubuntu.com/ubuntu/ precise-updates/universe libpanel-applet-4-dev i386 1:3.4.1-0ubuntu1.1 [11.7 kB]
Get:4 http://gt.archive.ubuntu.com/ubuntu/ precise-updates/universe libpanel-applet-4-doc all 1:3.4.1-0ubuntu1.1 [96.3 kB]
Fetched 326 kB in 1s (210 kB/s)             
Selecting previously unselected package libgconf2-dev.
(Reading database ... 386366 files and directories currently installed.)
Unpacking libgconf2-dev (from .../libgconf2-dev_3.2.5-0ubuntu2_i386.deb) ...
Selecting previously unselected package libgconf2-doc.
Unpacking libgconf2-doc (from .../libgconf2-doc_3.2.5-0ubuntu2_all.deb) ...
Selecting previously unselected package libpanel-applet-4-dev.
Unpacking libpanel-applet-4-dev (from .../libpanel-applet-4-dev_1%3a3.4.1-0ubuntu1.1_i386.deb) ...
Selecting previously unselected package libpanel-applet-4-doc.
Unpacking libpanel-applet-4-doc (from .../libpanel-applet-4-doc_1%3a3.4.1-0ubuntu1.1_all.deb) ...
Setting up libgconf2-dev (3.2.5-0ubuntu2) ...
Setting up libgconf2-doc (3.2.5-0ubuntu2) ...
Setting up libpanel-applet-4-dev (1:3.4.1-0ubuntu1.1) ...
Setting up libpanel-applet-4-doc (1:3.4.1-0ubuntu1.1) ...

Great, the configure still complains the exact same message of not found version 2. I have version 4 installed and running:

$ whereis libpanel-applet-4
libpanel-applet-4: /usr/lib/libpanel-applet-4.so

Any ideas? I am running version 4.8 of XFCE4.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The problem actually is that Xfapplet was designed to run GNOME2 applets. Since there are no applets for GNOME3 (only extensions and indicators), and the plugin itself hasn't been updated upstream in almost 6 years, there was no good reason for maintaining packages for it. So, even if you get that working by installing old packages from GNOME2, it won't be for a long time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.