Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 on a Samsung Series 5 530U3C-A0J and while Ethernet works, I am having trouble with wireless LAN. It manages to establish a connection to my router without any problems, but that's it. I cannot actually use this connection, e.g. pinging my router leads to 100% packet loss, while doing the same with ethernet results in 0% loss.

Some info about the wireless chip (from lspci -nnk):

01:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6235 [8086:088e] (rev 24)
Subsystem: Intel Corporation Centrino Advanced-N 6235 AGN [8086:4060]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

I'm not allowed to answer my own question, so here's an edit:

Okay, what I did was

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

So it seems like n-WLAN is the problem. To permanently make this work, I added options iwlwifi 11n_disable=1 to /etc/modprobe.d/iwlwifi.conf as first line after the comments.

It seems to work, but can somebody tell me if this was the right way to get it working? Because wireless still needs much more time to initially establish the connection than it took with my old notebook and debian.

share|improve this question
1  
It is the well-known work-around for a long-standing bug in iwlwifi. What you did is correct. –  chili555 Apr 17 '13 at 20:14
    
@Florian R. It's encouraged to answer your own question. See here blog.stackoverflow.com/2012/05/encyclopedia-stack-exchange and please do! Your efforts help us all! –  Elder Geek May 7 at 13:35
    
@ElderGeek Done, thanks for reminding me. When I asked this, I didn't have the required reputation yet. –  Florian R. May 7 at 15:55
    
@FlorianR. My pleasure! Welcome to the crew! –  Elder Geek May 7 at 16:16
    
For me, the solution above did not work. I had to manually set the speed of the WiFi network to 54 Mbps on my router - then I could connect without problems. –  user313212 Aug 7 at 7:44

1 Answer 1

up vote 2 down vote accepted

Since I'm now allowed to answer my question:

Okay, what I did to test this was:

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

So it seems like n-WLAN is the problem. To permanently make this work, I added options iwlwifi 11n_disable=1 to /etc/modprobe.d/iwlwifi.conf as first line after the comments.

This was confirmed by chili555's comment.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.