Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.04 and my problem arises when I use CTRL+ALT+F# keys in VirtualBox (Windows XP guest).

Unfortunately, I have a number of CTRL+ALT+F# key shortcuts set up in a Windows application, which I am so habituated to using that I find myself doing so despite my best intentions not to, most frequently CTRL+ALT+F12. The screen goes white, rather than presenting a terminal interface, which may (my research suggests) be because I have a Nvidia graphics card (I don't know whether I'm using the Nouveau or Nvidia proprietary drivers).

Google and Askubuntu tell me these key combiations are intercepted by the host and are taking me to a tty terminal and that I should be able to get back to the GUI using CTRL+ALT+F7. I can't, however, CTRL+ALT+F7 has no effect and in fact the only solution I have found is to do a hard reset.

I'm fairly new to Ubuntu, so please bear with me on this. Many thanks for any assistance.

share|improve this question
    
Did you try another Ctrl+Alt+F# like F8 or F9 or something else? Check the answers in this question for a reference. –  Dan Apr 17 '13 at 10:45
    
Thanks for your response and the link. I have indeed run through all 12 CTRL+ALT+F# key combinations with no success. Also, I just tried using CTRL+ALT+F1 outside of VirtualBox (with no programs running), and got almost the same result (a blank, backlit screen, rather than a white screen), from which I was also unable to escape other than by a hard reset. –  Jeremy Amos Apr 17 '13 at 12:09
    
I found a workaround which works for me here. This resolves my problem, but I'd still be grateful for any info on why I can't escape from the tty and how to fix that. –  Jeremy Amos Apr 17 '13 at 12:48
add comment

1 Answer 1

If your setup is like mine, right-CTRL (aka the host key) and F1-6 change tty, and right-CTRL+F7 should take you back to the GUI.

share|improve this answer
    
this isn't right. ctrl-alt-f# switches things but not ctrl-f# by itself. –  amc Jul 21 '13 at 1:48
    
The original poster is using VirtualBox, as am I. This is how things work under VirtualBox. –  SamStephens Jul 21 '13 at 2:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.