Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I originally had Windows Vista, later upgraded to 7.

Then I used wubi to install Kubuntu alongside Windows 7 - my load screen became the black one with white writing (grub legacy I believe).

Then I (deliberately) somehow deleted Kubuntu, though I can't remember how. I may have just removed the partition!

Then I installed an SSD, and cloned Windows 7 partition to the SSD.

Then I installed Ubuntu on the original drive, and deleted the old Windows.

The problem is that somehow I've ended up with two boot screens.

The first is the blue screen (grub 2 I believe) which lists Ubuntu and Windows.

Ubuntu boots fine, but if I select Windows, it takes me to the original black and white boot screen, offering Kubuntu and Windows 7. Unfortunately, both of these options no longer point to an existing OS, and the real Windows 7 is hidden!

I tried using boot-repair, but same result. I've linked the disk summary from boot-repair below.

http://paste.ubuntu.com/5714899/

I guess the problem must be that there is an old grub legacy hanging around somewhere - how can I get rid of it?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Alex, You installed Kubuntu using wubi, that's called inside windows installation not alongside.

In wubi installation , kubuntu splits windows bcd file and creates entry for kubuntu. When kubuntu crashed, you needed to fix windows bcd using rebuild bcd command as guided here, beacuse grub installs after splitting windows' bcd file.

This will remove old grub completely. After this You will able to boot windows only , and you need to reinstall grub. After successfully grub installation you will get both boot entries.

share|improve this answer
    
Thankyou, I gave this a try... Unfortunately I cannot seem to access the SSD from Windows Recovery Environment. I'll give it another try later without the other disk connected, maybe that will help. –  Alex Apr 18 '13 at 1:47
    
Ok, starting from your suggestion, I've eventually managed to restore windows booting... but it still goes to the old grub screen with the phantom Kubuntu! Now trying instructions here... and that works. Thankyou! –  Alex Apr 18 '13 at 14:25
    
Well come, friend. –  K.K Patel Apr 19 '13 at 3:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.