Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Lenovo Thinkpad Edge 13 (Intel model)

I've gotten everything to work under Ubuntu except for hibernation. The system hibernates normally but when Ubuntu tries to boot from the hibernation file, it freezes.

I tried with the 2.6.35 kernel and the newer 2.6.36 (which solved my eating-battery problems), but this issue persists.

How could I troubleshoot this issue?


  • My Ubuntu install is in a separate partition alongside Windows 7.

    I've tried a BIOS update today, and the problem still persists.

    My swap partition is bigger than my installed Ram (2,3GB vs 2,0 GB)

Suspend as a sleep method works, but I really need my hibernation option.

share|improve this question
can you provide us more information on how your ubuntu is installed; wubi? another work around is using standby – myusuf3 Feb 26 '11 at 18:44
Is it really a freeze or does it only take unusually long like 10 min or so (I've seen that before)? – Takkat Feb 26 '11 at 20:49
@dustyprogrammer I'll add the info in my question – bruno077 Feb 26 '11 at 21:10
@Takkat it's a real freeze, the only way to recover the computer is my rebooting – bruno077 Feb 26 '11 at 21:10
I'd recommend you open a new question about this issue giving detailed info about your hardwar. – bruno077 Mar 23 '11 at 19:40

I would try a BIOS update as there seems to be some issues with power in the past. I have known BIOS updates to solve these issues. Try here.

share|improve this answer
Thank you, both for the info and the link; but BIOS update didn't solve the problem unfortunately =(, still looking for the solution – bruno077 Mar 28 '11 at 19:27

There are often clues in /var/log/messages. Look for what the kernel said around the time of the crash or hibernate attempt.

share|improve this answer
I didn't know this, will try today =) – bruno077 Mar 28 '11 at 19:26

You could do the following

  1. Update the bios
  2. Install the latest kernel
  3. Install the proprietary graphics driver
share|improve this answer
up vote 0 down vote accepted

I fixed it. Turns out it was the package


which replaces the default hibernate and sleep methods, the one that was causing the freezing. I uninstalled it and reverted to the default Ubuntu hibernate and it works flawlessly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.