Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an internet sharing server which is connected with a hdd with music I'd like to listen via wifi.

I have tried creating a samba or ftp share, but they are so slow (or I just do not know how to make them faster =) ). So I have tried to share via NFS.

I have followed this guide: https://www.digitalocean.com/community/articles/how-to-set-up-an-nfs-mount-on-ubuntu-12-04, and I was able to connect, but when I go into a dir, to where my hdd is mounted, I can see nothing.

On server:

/srv/share ➜  ls -l 
total 24
drwxrwxrwx 1 root root 24576 Apr  2 16:15 hdd
-rw-rw-r-- 1 abra abra     0 Apr 16 21:22 hello
-rw-rw-r-- 1 abra abra     0 Apr 16 21:19 hi
/srv/share ➜  ls hdd
...various dirs...

On client:

~/server ➜  ls -l
total 4
drwxrwxr-x 2 abra abra 4096 Apr 16 21:19 hdd
-rw-rw-r-- 1 abra abra    0 Apr 16 21:22 hello
-rw-rw-r-- 1 abra abra    0 Apr 16 21:19 hi
~/server ➜  ls hdd
~/server ➜      

Or maybe NTS is just an overkill and there is an easier way to share mounted hdd fast via wifi?

Thanks in advance.

EDIT:

My /etc/exports

# /etc/exports: the access control list for filesystems which may be exported
#       to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync,no_subtree_check) hostname2(ro,sync,no_subtree_check)
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt,no_subtree_check)
# /srv/nfs4/homes  gss/krb5i(rw,sync,no_subtree_check)
#
/srv/share  192.168.0.0/24(rw,nohide,insecure,no_subtree_check,sync)
share|improve this question
    
By default, Nfs exports don't include mounted directories. If you export a folder on the mounted hdd, it should work. I don't remember by heart, if there's also an option one can specify in exports to transgress filesystem boundaries. Maybe you should read the exports man page. –  soulsource Apr 16 '13 at 17:55
    
Please add the Solved bit as an answer, and mark this question as solved. –  nfirvine Apr 16 '13 at 18:09

1 Answer 1

up vote 0 down vote accepted

I've just had to add

/srv/share/hdd  192.168.0.0/24(rw,nohide,insecure,no_subtree_check,sync)

in /etc/exports and it works.

There is an option crossmount to add in exports, but I didn't manage to get it work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.