Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here is what I got:

A pre-installed Windows 8 64 bit pro laptop, with an SSD card (Samsung PM83) and a SATA HDD. It is a Vostro 3560 from Dell.

First thing I did was create a recovery disk for Windows 8 and get an image so I can burn a clean install disk for Windows 8. Afterwards, I tried to install Ubuntu.

After setting BIOS to legacy mode, setting secure boot to off, I went on with th Ubuntu LiveCD. I tried to get a partition on the SSD card for / and for swap, but it had some issues with putting swap on that disk.So I tried the default installation on the SSD card. It starts nice, it says it is Copying files, but almost halfway through it shows the installer crashed due to a ErrNo5, I/O error.

Every single setting I change (using different file system or UEFI boot mode) results in the same error.

Has any had this before as well? Were you able to fix it?

Kind regards.

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

How did you create the partitions? When I tried to create partitions in my Samsung 840 Pro SSD using Windows I also had problems, so I booted the LiveCD and used GParted instead which worked great.

As far as installing Ubuntu on SSD goes, I have a clean Ubuntu 12.10 installation on the SSD disk I previously mentioned, but there is one catch: I have no swap partition. Why no swap partition (you may ask), is this man insane? Well, I figured that with 8GB of RAM in my machine, I don't need swap. I never reached the 8GB limit, and I don't think I will in the nearby future.

If your computer also has a lot of RAM, you may want to consider this solution. If not, you could try and create the swap partition in your HDD instead of creating it in the SSD.

Wish I could be more helpful, this is all I got :s

EDIT: Looks like some Samsung devices are bugged!. I don't know but this may be your case.

share|improve this answer
1  
Ok, I went with the simple solution. I tried a Debian Squeeze CD I used to install a server some time ago. It worked! I think my Ubuntu CD was not written properly... Thank you for your replies, as I will try to install Ubuntu again later on. For now I keep Debian just to see what this SSD card can do. As for your questions: Rod Smith; I wanted a fresh Linux install, so I could use either VMWare or VirtualBox and run Windows there. Flame_Phoenix: I tried using GParted, but it didn't recognise my cards at start. After some restarting it did however. I think it's due to the crappy CD... –  Mark Apr 16 '13 at 17:36
    
Good to know you fixed it :P –  Flame_Phoenix Apr 18 '13 at 15:25
    
And happy too :-) –  Mark Apr 19 '13 at 8:15
add comment

An I/O error during installation reeks of a hardware problem. You might want to try doing a SMART test on the disk, reseat or replace cables, etc.

As a side note, if you want to set up a dual-boot Windows/Linux configuration, you should not install Linux in BIOS/CSM/legacy mode. With Windows 8 pre-installed, it's almost certainly in EFI mode, and switching boot modes is awkward with most computers. Instead, install Linux in EFI mode, which is likely to be easier to get working.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.