Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want NetworkManager to automatically connect to the wireless network. I've configured my account to automatically log in (using System > Administration > Login Window) and I get prompted to unlock my GNOME keyring.

From researching this, it would appear that I should be able to disable the security on the keyring by blanking the password. However, if I change the password of the default keyring to blank so that it uses "Unsafe Storage" and automatically log in, I am prompted with a "Wireless Network Authentication Required" request. The password field is already filled in but does not seem to have been used.

So how do I convince NetworkManager and the GNOME Keyring to work without requiring me to log in with a password, or to enter my keyring password?

share|improve this question
    
this is a duplicate of: this and this –  krumpelstiltskin May 18 '11 at 15:23
add comment

2 Answers

up vote 3 down vote accepted

There are two ways to do that:

  1. Remove Password and Encryption Keys (seahorse), the program responsible for keyrings.
  2. The alternative is to edit your wireless connection, and tick the last checkbox to make it available for all users. In this case, the network will be connected to before signing in, at the login (if there are multiple users or the only user account is password protected).

Of course, the second method is preferable if you still have uses from GNOME-Keyring.

share|improve this answer
    
I've changed the wireless connection to make it available for all users and it's been working for a few days now, so thanks Oxwivi! –  user8979 Mar 5 '11 at 9:56
add comment

Solution 2) works fine but has an disadvantage:

only 1 Wifi network can be marked as "available for all users". If you want to connect to another Wifi, you will be prompter for password each time you connect.

I found following solution.

Config (for reference):

  • Ubuntu 10.04 Lucid, localized to Slovak language
  • Autologin
  • Unsafe keyring (no password)

Procedure:

mpilka@mpilka:~/.gnome2/keyrings$ rm -f default
mpilka@mpilka:~/.gnome2/keyrings$ mv predvolený.keyring login.keyring

Both autologin and NetworkManager remembering passwords now works.

Edit: "predvolený" translates to "default" in English.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.