Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Gigabyte 970A-D3 with an AMD Phenom II CPU and I'm trying to install an OS. This is not my first rodeo installing Linux. I've tried booting to the live OS for Ubuntu 12.10 and Lubuntu 12.10 and after it loads the OS, the mouse and keyboard do not respond. The USB mouse and keyboard work fine inside the BIOS and during language selection for the Live CDs. I've tried different USB ports, still no good. This is a UEFI motherboard, but I'm not booting to UEFI mode. Are there any BIOS settings I can look at that might help?

Note: Legacy USB support is enabled. I have tried different mice and keyboards. When I get to the screen that allows me to either Try or Install Ubuntu, the keyboard works fine. A PS2 mouse works.

share|improve this question
1  
Terminal is pretty useless without a keyboard, I forgot about that lol. Going to remove my answer to get your question unanswered. I also missed the point where you say you can select language. It then is not a BIOS issue. –  Takkat Apr 16 '13 at 10:16
    
Can you please add the USB ID for the keyboard and mouse (output from lusub), to assist others. –  david6 Apr 17 '13 at 2:16
1  
I couldn't get output from lsusb. The keyboard did not work. –  Ed Manet Apr 17 '13 at 15:00
add comment

2 Answers 2

up vote 3 down vote accepted

I found the solution to this issue. The trick is to enable (at least on Gigabyte Motherboards like the 970a series) IOMMU in the peripherials tab. It is ab option with no description close to the bottom of the menu. Only 2 options, enable or disable. Enable the option save the setting and reboot. Surprise! All of you USB devices are now functional again. More about IOMMU here

share|improve this answer
    
That motherboard has been sitting on a shelf for 2 months. Can't wait to try this solution. Thanks! –  Ed Manet Jun 5 '13 at 13:23
add comment

The answer really was to replace the motherboard/CPU. Maybe it was the combination of the two models I bought. I replaced them with an Intel i5 and an MSI motherboard. Everything worked out of the box.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.