Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run kernel 3.5.0-27-generic on Ubuntu 12.10 (Pretzlyquantumbear!?)

Somehow, I have installed Nvidia driver 310.32, and X11 will not start unless I at each boot go and run make install in nvidia-current-updates-304.88.

How do I get the correct driver, 304.88, into the initrd?

I have tried update-initramfs -u to no avail.

It gets kind of old to do, at each reboot:

  • Hold Shift to GRUB menu appears
  • Select Special boot
  • Select Rescue
  • Enter root shell
  • remount -n -o remount,rw /
  • cd /usr/src/nvidia-current-updates-304.88 && make install
  • logout
  • Select resume boot
share|improve this question
    
Have you removed driver 310.32? –  Salem Apr 16 '13 at 12:17
    
@Salem, no how do I do that? –  Prof. Falken Apr 16 '13 at 12:26
    
What is the output of dpkg -l | grep nvidia? (use paste.ubuntu.com or something similar to post that information) –  Salem Apr 16 '13 at 12:53
    
paste.ubuntu.com/5713172 @Salem . It's all 304.88 –  Prof. Falken Apr 16 '13 at 13:34
add comment

1 Answer

It seems from here you have two mixed drivers installed:

  • 310.X installed manually (with the installer from nVidia website);
  • nvidia-current-updates from Ubuntu repos.

First of all you will need to uninstall the 310 driver. If you installed it from a .run file downloaded from nVidia website, you can do that using:

sudo sh /path/to/NVIDIA-Linux-<version>.run --uninstall

After this you can install some driver from the default repositories. If you need to use a 310 driver you can install the experimental one:

sudo apt-get install nvidia-experimental-310

despite being named "experimental" I used it for some time and had found no problems at all.

Or you can stay with the 304 driver you already have:

sudo apt-get install --reinstall nvidia-current-updates

If after rebooting you still need to compile the driver before each startup, check the following:

  • Check you have dkms installed: sudo apt-get install dkms;
  • Check you have the kernel headers needed to compile the module: sudo apt-get install linux-headers-$(uname -r)
  • Run sudo update-initramfs -u and watch for warnings/errors.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.