Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.10 to Asus Zenbook Prime UX31A. Now I face a resolution problem. The default resolution is 1920x1080. But everything is too small with this resolution. Icons, Unity, file system, browsers etc. For example in Chrome only when I set the zoom to 150% sites view normal. When I use the 16:9 resolution 1360x768 the size problem is fixed, but in this mode the display colours and view are blurry and thick, so it harms the eyes. And as my display supports 1920x1080, I think that I better keep this native resolution and fix size problem instead.

some Screenshots: Screenshots 1, Screenshots 2

How can I solve this and get the desktop displayed in an acceptable size?

share|improve this question

5 Answers 5

EDIT: Ubuntu 14.04 sort of supports high resolution screens and allows you to scale the panel and launcher with a simple slider under System Settings -> Displays. It's still a bit buggy: it doesn't work for some apps like Spotify doesn't scale and Thunderbird don't scale icons and the content of the emails.

So while Ubuntu took a giant leap forward, the below solution is still the only fully functioning way of scaling everything on Ubuntu.


You can scale everything with xrandr but the result is not as pretty as it could be if there was true high resolution support.

To scale your resolution, first find the name of your display with xrandr:

lars:~$ xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 1600 x 1600
LVDS connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768       60.0*+
   1280x768       60.0 +
   1280x720       60.0 +
   1024x768       60.0 +
   1024x600       60.0 +
   800x600        60.0 +
   800x480        60.0 +
   720x480        60.0 +
   640x480        60.0 +
DFP1 disconnected (normal left inverted right x axis y axis)
CRT1 disconnected (normal left inverted right x axis y axis)

So, in my case my laptop display is called LVDS.

Then run the following to scale your resolution:

xrandr --output LVDS --scale 0.75x0.75

The Launcher and Panel might disappear for a moment, but just hover your cursor over them and they should reappear. You might also have to resize any open windows so that they fit the smaller resolution.

I wish there was true high resolution support that was this easy to configure. Sadly even GNOME 3.10 seems to only support changing the font size, even though GNOME handles that a lot better than Unity.

share|improve this answer
    
Great answer. I was looking for this for a long time. –  Developer Android Jun 17 at 10:16
    
The "fully functioning way" didn't work at all on my Lenovo Yoga Pro 2: when I entered xrandr --output eDP1 --scale 0.75x0.75 The resolution changed, but the correlation between the position of the mousepointer and the screen was lost. also I could move the mouse far out of the screen at the bottom into some inaccessible area. Using the System settings -> Screens is the far better solution and works well on my Firefox 30 –  rubo77 Jun 19 at 8:44
1  
open a new tab about:config in Firefox and search for layout.css.devPixelsPerPx set this value to 2 to adjust the size of the Firefox icons, see Adjust Firefox to a High DPI display (retina) –  rubo77 Jun 23 at 7:59
1  
Wow, that actually works! It also works under Thunderbird, you'll find the Config Editor under Edit -> Preferences -> Advanced. Thank you, this is awesome! –  Lars Nyström Jun 23 at 8:05
1  
You can add to bug heat here: bugs.launchpad.net/ubuntu/+source/unity-webapps/+bug/1333158 –  rubo77 Jun 23 at 10:33

Open dconf-editor and goto /org/gnome/desktop/interface/text-scaling-factor and adjust the scaling. Calculate the scaling by 1920/screen width in inches/96, assuming that you display is set to 96dpi now (check with xdpyinfo | grep dots). You can play a bit with he scaling factor to get to a size you like.

Note: This only changes fonts and some UI elements but not the browser contents. To do this you need to run all of X11 with a higher dpi setting of around 160. This can be done by adding

xrandr --dpi 160

to your ~.xprofile.

share|improve this answer
1  
Thank you, i did same as you said. All fonts got normal size. (i adjusted 1.5 to scale as 1920/(96*13.3)~1.5. But only text problem fixed. Other interface parts(such as unity,nautilus,terminal and all other packages' panels&images&icons) are the same even after changing dpi to 160. When i change dpi via terminal, nearly nothing happens. Only screen twinks once, and no any visual seeable change i feel. –  Elvin85 Apr 17 '13 at 8:28
    
It only worked for me when adding the line to .xprofile and restarting X11. I had to create .xprofile on my system. I made it executable too. From the terminal it does not seem to have any effect. It seems to be that this setting has to be applied at the start of X11. –  rfindeis Apr 17 '13 at 19:03
2  
One more: Some tools insist on their own dpi settings (96 usually). Firefox has a setting layout.css.devPixelsPerPx in about about:config. Set to the ratio of the desired dpi and 96. Raising the dpi value across the system is quite a challenge. –  rfindeis Apr 17 '13 at 20:05
1  
I poked around a bit more and found the some window managers ignore all dpi settings. See here for an explanation: askubuntu.com/questions/197828/… I did not try hacking the code of gnome-settings-daemon. I think for now besides enlarging the fonts this is a lost case. –  rfindeis Apr 17 '13 at 20:57
    
Thank you very much rfindeis. Last link you gave 80% solved my problem :) Now only some icon and panel problems are still existings. Such as Chrome tab-headers are too small (also was Chrome content, but i enlarged it to 150% via Chrome settings, and now it's ok), Unity icons are smaller than normal(but fonts are quite well now), thats all. I think i should find any guide which will help me to zoom all system panel and icons yeah? –  Elvin85 Apr 18 '13 at 4:34

Starting with 14.04 we have an option that helps a bit:

Scaling Support

open the System Settings (here in english:)

LANG=c unity-control-center

Go to "Displays" and set the "Scale for menu and title bars":

enter image description here

To adjust Firefox, open a new tab about:config in Firefox and search for layout.css.devPixelsPerPx set this value to 2 to adjust the size of the Firefox icons - The same with Thunderbird

see also:

share|improve this answer

I think this is a problem that hasn't been addressed, yet. The retina display on some Apple computers has a resolution of 2880 x 1800. (Take a look at how ubuntu looks on one of these.) That's only any good if the icons etc. are actually displayed at a higher resolution as well.

For the moment, you can halve your resolution and get something of a decent size or use your ubuntu with a magnifying glass...

As more and more high-resolution displays hit the market, I figure that ubuntu will have a solution for this fairly soon, though.

share|improve this answer
    
Would you know if there have been any announcement for high-res display support in the coming ubuntu versions? –  Peter Smit Feb 6 at 7:22
    
Ubuntu 14.04 has some support for high DPI screens. I, however, only found a way to scale titlebars and menus, not content - in Display settings. –  Suor Apr 18 at 4:28

I had the same problem with my Vaio SVZ13114GXX. Give Unity Tweak Tool a try, I tested many different combinations from Appearance and ended up with changing font size from 11 to 13, and setting hinting to full. Test on your own system for best results.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.