Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new Macbook pro 15'' retina display laptop running OS X 10.8.3. I am running virtualbox 4.2.12. I downloaded Ubuntu 12.04 LTS earlier today and installed it as a virtual machine from the iso.

I then installed many packages to run Theli (details below). I did the normal

sudo apt-get update
sudo apt-get upgrade 

and then installed all the bits I needed, plus the software I need the virtual box for. Everything was working fine. However, when I powered off the VM and then tried rebooting it a while later it does not boot. I see the virtualbox window appear (where I can hit F12) then the screen goes black/brown and nothing happens.

The VM rebooted several times during the upgrades and package installs with no problems. I've spent a couple of hours getting it to the way I need it and now it's not booting. Any ideas?

Theli is used for reducing astronomy data. I installed all of the dependencies once the VM was up and running, then installed Theli itself. It compiled with no errors and ran fine afterwards. Please let me know if I can provide more information to help further.

EDIT: I had not installed the guest additions, It was not suggested in the Theli installation guide, and I am new to Ubuntu so I did not know about them. Do you think this could cause the problem? I can reinstall everything from scratch to try.

EDIT: I just started from scratch with a new install of ubuntu 12.04 LTS. I started up the VM and ran:

sudo apt-get update
sudo apt-get upgrade

and then I shut the VM down, waited a few sec and powered it up again. It started fine. I then went and installed all the prerequisites for Theli (see below), I shutdown the VM as before and after installing the things below the VM no longer starts up. Can anyone spot something in there which could cause this?

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install gfortran csh g++ libqt3-mt-dev gawk gettext wget
sudo apt-get install tcl8.5-dev tk8.5-dev netpbm imagemagick libfftw3-dev
sudo apt-get install xorg-dev pgplot5 libtiff4 libtiff4-dev libpng3
sudo apt-get install binutils-dev build-essential libtie-ixhash-perl
sudo apt-get install libncurses5-dev perl xterm gzip pdl emacs nedit cmake
sudo apt-get install python python-dev python-numpy libxxf86vm-dev
sudo apt-get install python-scipy python-matplotlib libgsl0ldbl libgsl0-dev

UPDATE: I went through installing the prerequisites above one by one on a fresh install of Ubuntu 12.04 LTS 64 bit. I found that after installing the xorg-dev package the VM would no longer boot. I have installed all the others and their prerequisites via apt-get and things seem to be fine. I am not sure what in xorg-dev (or its prerequisites) is causing the problem.

share|improve this question
1  
Rather than adding a comment we like to encourage you to edit your question to add relevant details. I did that for you so that you can now delete your comment to reduce clutter. Had you installed the guest additions in your VM? –  Takkat Apr 16 '13 at 7:19

1 Answer 1

You don't have to reboot after those commands. Reboot is only required after installing a new kernel, and that does not happen on an upgrade - only on a dist-upgrade.

First, take a snapshot of the virtual machine, while it is running:

  • either click on the camera in the VirtualBox GUI,

  • or press the virtual machine window's "close" button and then "Save the machine state".

Then, shut down the machine via the Ubuntu interface (not the VirtualBox menus, nor the virtual machine's close button).

Finally, check whether you can reboot. If you can't, restore the snapshot (click on the icon with the ^ symbol in the VirtualBox GUI) and start the machine.

share|improve this answer
    
Hi Ignis, I know I did not have to reboot after doing those commands, I was trying to figure out where in my installation procedure was causing the problem. I tried what you suggested, taking snapshots after installing several things and then rebooting to see if it started up ok. I have made three batches of prerequisite installs, making a snapshot after each and the VM has booted fine after each one. I have no idea what went wrong before. I was using the ubuntu showndown option, not the VB options. Strange. I will continue with the install this evening and post again if I find problems. thx! –  James McCormac Apr 18 '13 at 17:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.