Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to install fgrlx 13.3 from the AMD website, the installation goes smoothly, but when I to aticonfig --initial -f, I get the following error:

    Uninitialised file found, configuring.
    PowerXpress info: Diagnostic output from /usr/lib64/fglrx/switchlibglx:
    update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ because link group x86_64-linux-gnu_gl_conf is broken
    update-alternatives: warning: not replacing /usr/lib/x86_64-linux-gnu/xorg/extra-modules with a link

Then when I boot, X won't start.

Does anybody have an idea of how to fix this? Is there a special installation procedure or version I should be using for 13.04 beta? I'm on xorg-edgers right now, but I could easily revert them.

My video card lines in lspci are as follows:

    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler [Radeon HD 6600M/6700M/7600M Series]
share|improve this question
I think the aticonfig is the problem look at this link… and pay attention to the second comment on this page - worked for me good luck – user117967 Apr 17 '13 at 4:46
13.4 is released have you tried it ? – Arin Chakraborty Apr 25 '13 at 19:40
Trying it now. At first, no luck, but I'll try the version in xorg edgers. – jmite Apr 25 '13 at 23:12
I get the same error when I do aticonfig --initial -f – jmite Apr 25 '13 at 23:42
up vote 0 down vote accepted

BastiFantasti outlines a solution for 13.4 at

Basically, it requires getting older versions of the Intel drivers, and running

aticonfig --px-dgpu

after before rebooting.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.