Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying to install Ubuntu 12.04 (64-bit) on my ASUS N75SF laptop, but Ubuntu can't get to the point of installing. It hangs immediately after entering the first purple screen ( the one where there is only the universal access picture which equals to a keyboard). It doesn't report any errors at all, even after being hanged for around an hour, then I downloaded Ubuntu again from a different source and put in on another CD, with no success. I also tried using the 32-bit version of 12.04 but it also hangs at the same point, while both versions of 10.04 work normally in Live-CD mode (haven't tried installing them). I updated my BIOS to the latest version available ( BIOS 214 from ASUS support page). I tried to see if Windows 7 (64-bit) installs, which it does, but i didn't go through with it. Currently, there is no OS installed on that machine, with the whole HDD formatted into two partitions via Hierns tools. One partition is ext4 and the other is NTFS if it means anything. AFter following the instructions on other similar topics, I got stuck at the point that they say I should turn off acpi_osi= and nomodeset but i can't enter grub and BIOS doesn't have such options.

ASUS N75S specs: Intel HM65 Express Chipset Intel Core i7- 2670qm cpu 8 GB RAM NVIDIA GeForceGT 555M 2GB 2.5" SATA 750GB 7200rpm

PS: I have a around 6 months of experience with Linux and have some knowledge on the Linux CLI. Additionally, I've installed Ubuntu 12.04 6 times before on 6 different machines, without any problems.

Edit: I checked the bios settings. UEFI is disabled, but i can't seem to find the option for Secure boot/CSM and fastboot.

share|improve this question
1  
I decided to try out other distro's until i could find a fix for this issue. So far I've tried Fedora 18, which has the same issue. Linux Mint 14, on the other hand works like a charm, except for Nvidia Optimus, but I am currently working on that. –  nixhitchhiker Apr 17 '13 at 13:57
add comment

1 Answer 1

has that pc secure boot enable?

https://help.ubuntu.com/community/UEFI

If that doesn't work, feel free to ask me to swap your useless pc with mine! ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.