Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The touchpad suddenly stopped working in my HP Pavilion laptop. External mouse works. I'm running Ubuntu 10.10. What are my options?

share|improve this question
It started working when I tried this:… But now the Touchpad tab in the Mouse preferences dialog is gone :S – thameera Feb 26 '11 at 11:59
Does it stop working completely, or only moving the pointer doesn't work, but, say, scrolling does at the same time? I have such a problem with the touchpad in Ubuntu on my Toshiba AC100 -- ,… – imz -- Ivan Zakharyaschev Sep 20 '12 at 15:09
up vote 3 down vote accepted

I recommend you use " touchpad-indicator" - an indicator applet for easily managing your touchpad. Installation instructions are given in this link.

share|improve this answer
I installed this and removed the edit I mentioned previously. After a restart, it works fine now. Dunno what happened. Thanks anyway! – thameera Feb 26 '11 at 13:04
you are welcome. – tinhed Feb 26 '11 at 14:44
Is there another source to download the app from? the code "sudo apt-get install touchpad-indicator" no longer works. – Matthew Wilson Jan 7 '12 at 13:05
And ... it works on the 12.04 beta 2, also, which means it will probably work as well when 12.04 LTS is released. – Kelley Apr 20 '12 at 17:24

Perhaps, switching to the linux console (say, Ctrl-Alt-F1) and back to X (Ctrl-Alt-F7) will make the touchpad work again. (This is a workaround around the bug, wothout a good fix and explanation.) --

share|improve this answer

Try restarting your mouse or touch pad using xinput. First you should know the id of your device, for doing so type in a terminal:

xinput list

A list with input devices will appear, notice the id of your target device, then type

xinput --disable [id]
xinput --enable [id]

replacing [id] with the device ID you want to restart. It should work now.

share|improve this answer

The easiest way to solve this problem is to pulse the FN+F7 (or the F-number with the symbol of the touchpad), always with the mouse not plugged in.

share|improve this answer

There is an option in the configuration system, mouse and touchpad section, that let you to disable the option of "disable touchpad when writing" or something (I'm translating literally from french), please paid attention this opoption is not checked. I solved this issue in 12.04, 12.10, 14.04 and 15.10 Ubuntu OS, and I think it's an unknown bug or something. If you have disabled that option you will never have any more problem with your touchpad.

share|improve this answer

I solved this problem by adding i2c_hid to the blacklist.

  • first we need to open the file:

    sudo gedit /etc/modprobe.d/blacklist.conf
  • and then we write the next line: i2c_hid

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.