Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to follow these instructions for setting up NFS server on 12.04:

 https://help.ubuntu.com/community/SettingUpNFSHowTo

/etc/default/portmap doesn't exist so I skipped that part.

After editing /etc/exports I tried to restart/start the NFS service but I get the following error which I don't understand, everything was installed from apt-get:

davidparks21@hadoop-fsimage-bkup1:~$ sudo service nfs-kernel-server start
FATAL: Could not load /lib/modules/3.5.0-27-generic/modules.dep: No such file or directory
 * Not starting NFS kernel daemon: no support in current kernel.

I should strongly note that this is a 12.04 LXC container that's running in a 12.10 host!

Update: Tested in a 12.10 LXC container and I get the same error.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Within an LXC container you cannot run NFS because it's kernel based (e.g. it will only run on the host). UNFS and other user-space NFS servers are an option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.