Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a Thinkpad W510 laptop running Linux Mint 13 (I figured I'd be safe asking this question since LM is an Ubuntu derivative, and in any case I believe my problem is distro-agnostic). I have two external monitors that I use at home, with the third laptop monitor turned off (it's on a shelf above my main desk, so the picture below accuracy describes my physical setup):

Three monitor setup

Now, whenever I turn on my computer, come back from suspend, etc; the "off" monitor is hidden behind everything:

Hidden third monitor

Typically I would say "eh, who cares if nvidia-settings doesn't keep the monitor settings properly" - the laptop monitor is off! Things display correctly!

My problem is I'm using Redshift to change my monitors' color temperature based on time of day. When the screens get into the configuration shown in the 2nd screen shot, it screws up the "redshift"ing on the left monitor. Basically, the left monitor does not change color and yet the right one does. I typically just fix this by popping into nvidia-settings and changing the display configuration, but we all know that if you've got do something menial n number of times, that's probably n-1 too many times.

share|improve this question
up vote 2 down vote accepted

1) In your home directory create a text file name it .redshift

2) Open this file with your favorite text editor such as vim or gedit

3) Paste this script and save it:

for i in {0..3} 
   redshift -m vidmode:screen=$i -t 5500:4000 &

you can use any argument as you like..

4) make this script executable with command: chmod +x ~/.redshift

5) Add a new line: sh ~/.redshift to the end of ~/.profile --this makes your script to run every time you log in.

6) You can add an alias to this script to run ii manually and fast whenever you like:

alias redshift=sh ~/.redshift

add this line to the end of ~/.bashrc file to make it persistant.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.