Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I managed to use Unity (slowly) and then installed Lubuntu. I restarted the machine and now I CAN'T GET X TO LOAD ON TTY7. I can switch to login terminals though. jockey-text tells me that I am using the kmod:vboxguest. I installed nvidia-common and tried to set it as default using jockey-text but jockey-text only detects the kmod driver.

I was going to report this on Launchpad but I don't think I understand about drivers in VirtualBox fully...can someone explain how to install and make default the nvidia-common driver in Ubuntu 13.04 Daily in VirtualBox?

System Specifications:

Guest RAM: ~1.5GB
Intel Pentium M Dual-Core @ 2.5GHz
NVidia GeForce 7050

Update 1: I rebooted and now I get [ OK ] in the top right with a flashing cursor.
Update 2: Found this. (Yahoo Answers post from 4 years ago that says that the virtual machine can't use things on your motherboard. Hmm).
Update 3: FIXED, just typed sudo lightdm in tty1 and that seemed to start it. (facepalm)
Update 4: ...or not...tried 'sudo lightdm' and it just came up with a load of text ending in [OK] on tty7. Restarted and now it won't boot at all.

Note: I was going to answer myself but couldn't (due to a low rep cooldown) and now it still doesn't work.

share|improve this question

marked as duplicate by Javier Rivera, Mateo, Jorge Castro, Thomas W., AgentCool Apr 22 '13 at 10:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Please add it as an answer and upvote+accept it. That way you get some reputation and others that see this question can directly see it has a workable solution (even it is as simple as you said ;) ) –  Rinzwind Apr 15 '13 at 7:36

2 Answers 2

up vote 0 down vote accepted

Using these commands should work:

  • To start LightDM type: sudo lightdm start
  • To Stop LightDM Type: sudo lightdm stop

If that don't work type: sudo su

  • To start LightDM type: lightdm start
  • To Stop LightDM type: lightdm stop
share|improve this answer
    
Still doesn't work, see this Confirmed bug: bugs.launchpad.net/ubuntu/+source/lightdm/+bug/969489 –  Ads20000 Apr 17 '13 at 20:38
    
(Works sometimes) –  Ads20000 Jan 2 at 14:46

Just typed 'sudo lightdm' in tty1 and that seemed to start it... (facepalm) Sometimes however, that doesn't work as a reliable workaround. lightdm got an update today and it doesn't fix the problem. Will report on Launchpad.

share|improve this answer
    
@Rinzwind Will accept this answer ASAP but I can't upvote my own post :P (great name btw, the ultimate coward indeed) –  Ads20000 Apr 15 '13 at 16:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.