Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Using 12.04 my printer a canon ip2600 will not print.

SystemSettings/printers shows it as installed, connected to local host, enabled, accepting jobs, shared and allowing printing for everyone. Yet it does not print.

I have tried to remove it but get a request for user name and password which I enter (I only have one password) but the password is listed as incorrect.

I need a sudo command which I can use to delete the printer so I can attempt to re-install it. As it is the printer is useless and I can not even uninstall it.

share|improve this question
    
How are you trying to remove it? Are you using the command line or a GUI method? –  Lucio Apr 14 '13 at 21:35
    
I tried uninstall using GUI but it will not accept my password. I need a sudo command. –  msanderz Apr 14 '13 at 21:42
    
But are you a sudo user? Because, you need enter a sudo password. If the GUI method doesn't work, the command line neither –  Lucio Apr 14 '13 at 22:01
1  
To further clarify: I am the only user of this computer. When I enter a sudo command I enter my password, as requested, and the command executes. However the SystemSettingg/printers GUI rejects my user name and password. –  msanderz Apr 14 '13 at 22:17
1  
Somewhat solved. OKAY, I added myself to group lpadmin and was able to delete the printer with the GUI. Now I have NO printer installed. Next I will try to reinstall the Canon printer, but not today. Enough fiddling, it is time for a coffee break. –  msanderz Apr 14 '13 at 23:00
show 2 more comments

1 Answer 1

I solved the problem by adding my user name to the "lpadmin" group. Since I somehow was not in that group I was not allowed to change anything related to the printer. Once I was in the group I was able to delete the printer. Now all I have to do is re-install the printer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.