Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm baffled. I've looked around for awhile on this but nobody seems to have quite the issue I do.

I have an ntfs partition for all of my stuff, and I want to run some programs off of it. However, I keep getting Permission denied.

Very well, I'll try sudo ./eclipse. Nope.

Okay, well, maybe I have to chmod. sudo chmod +x eclipse.
No error. ls -l. eclipse is still -rw-------. What?

Verbose output! sudo chmod -v +x eclipse
Result: mode of 'eclipse' changed from 0600 (rw-------) to 0711 (rwx--x--x)
Yay! Nope, ls -l reveals that it's still -rw-------.

I then open nautilus as root, and find the file, and try to do it from the GUI. Turns out the same thing happens. The "Allow executing file as program" option isn't disabled, but when I tick the box it unticks the moment my mouse leaves. What's going on?

mount reveals that this partition is mounted in rw mode, which I know is important.


fstab line is

UUID="755AF93248ACABD6" /s ntfs rw,auto,users,nls=utf8,umask=007,gid=46 0 0
share|improve this question
    
show us fstab line for this disc... option noexec would be my guess ;-) –  Rinzwind Apr 14 '13 at 19:43
    
hmm, yeah this ( ubuntuforums.org/showthread.php?t=1787053 ) suggests it's something like that. hangon and let me restart to check –  MalcolmOcean Apr 14 '13 at 19:47
    
nope, fstab line is UUID="755AF93248ACABD6" /s ntfs rw,auto,users,nls=utf8,umask=007,gid=46 0 0 –  MalcolmOcean Apr 14 '13 at 19:49
    
You're having this problem? askubuntu.com/questions/30243/… –  hbdgaf Apr 14 '13 at 19:53
    
Okay, so sure, if I follow the instructions and run sudo mount -t ntfs -o fmask=0022,dmask=0000,uid=1000,gid=1000 /dev/sda7 /media/testmount then it works. But how do I fix this in fstab? –  MalcolmOcean Apr 14 '13 at 20:21

1 Answer 1

With "ntfs permissions are set at the time of mounting the partition with umask, dmask, and fmask and can not be changed with commands such as chown or chmod."source

Try changing umask=007 to dmask=027,fmask=037

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.