Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I use proxy to connect to the Internet. I am trying to upgrade to 12.10. The problem is that some(nearly all) packages are downloaded but some 3 Mb data is not downloading, due to which the upgradation aborts reporting a forbidden error. These are some files related to gnome-games and facebook integration. Facebook is blocked on the proxy server which i am using, so i guess the error appears due to that. I want to ask if there is any way i can skip downloading the last 3 Mb packages(which i don't need) so that my upgradation continues to Ubuntu 12.10? This is the error i am getting:

Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-games/gnomine_3.6.0.2-0ubuntu1.2_i386.deb 403  Forbidden
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-games/mahjongg_3.6.0.2-0ubuntu1.2_all.deb 403  Forbidden
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-games/gnome-mahjongg_3.6.0.2-0ubuntu1.2_i386.deb 403  Forbidden
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-games/gnome-sudoku_3.6.0.2-0ubuntu1.2_all.deb 403  Forbidden
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gnome-games/gnome-games-data_3.6.0.2-0ubuntu1.2_all.deb 403  Forbidden
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/a/account-plugins/account-plugin-facebook_0.8-0ubuntu2_i386.deb 403  Forbidden
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/g/gwibber/gwibber-service-facebook_3.6.0-0ubuntu1.1_all.deb 403  Forbidden
share|improve this question
    
Put the exact error text here. Without it we can't help figure out how to fix this. –  Thomas W. Apr 14 '13 at 18:04
    
I have updated the post with the exact error –  user149327 Apr 14 '13 at 18:08
    
Have you tried using a different archive mirror, perhaps one of the regional ones? (403s happen sometimes) –  Thomas W. Apr 14 '13 at 18:08
    
How do i do that? –  user149327 Apr 14 '13 at 18:09
2  
Go to System Settings--> Software Resources--> Ubuntu Software Tab, and change Download server. –  Mitch Apr 14 '13 at 18:14
show 3 more comments

marked as duplicate by Eric Carvalho, Jorge Castro, RolandiXor Aug 19 '13 at 16:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

If you don't want to upgrade/install those packages, is actually very easy. If you don't use them just uninstall them:

sudo apt-get remove <packages to remove>

To prevent that they try to get installed/upgraded you could put them on hold:

echo <package> hold | sudo dpkg --set-selections
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.