Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know there are similar questions, but none refer to the way I go about it. Freezes are not regular and I can't reproduce them.

When it does happen, it usually completely freezes for about 10 seconds (sound glitches and no keyboard or mouse moves) after which it comes back for 2-3 seconds and then it repeats. I usually get rid of this by ALT+CTRL+F2 or F1 and issuing top and waiting for a chrome process that uses around 50 to 60 % of the processor to go down (couple of seconds).

Other times the main process eating resources was Clementine (the music player) but that was only around 30%.

After the process goes below 10% I go back to Ctrl+Alt+F7 and it doesn't make any more problems.

How to solve this freeze?

share|improve this question
1  
I'm not certain this is exactly what you're looking for - but I have Chromium installed on 12.10 & 13.04 and have not experienced this problems. –  pfeiffep Apr 14 '13 at 14:35
1  
How much RAM do you have and what is your CPU? Chrome is a resource-hungry process, and the default DE (GNOME) is also resource-hungry. You might want to consider installing something lighter. –  Alex Apr 14 '13 at 15:48
1  
@Alex haven't had problems with Chrome on PC. I have 2 GB of RAM and a Intel Dual-Core clocked at 2GHz –  Silviu Apr 14 '13 at 16:01
    
What're you running in Chrome at the time of the freeze? what sites/applications/flash or java things/etc.? –  Thomas W. Apr 14 '13 at 16:21
2  
@Silviu I'd have to track chrome's threads usage more in Linux, but I believe that for each tab you have chrome launches a thread or sub process. The longer you have it running, like Firefox, the more RAM and CPU usage it has. It never hurts to close the browser every couple of hours, so that your system doesn't get overloaded with resources (chromium behaves similarly, but in a more sane way in that it doesn't gobble up CPU and RAM when idle) –  Thomas W. Apr 14 '13 at 17:55
show 1 more comment

1 Answer 1

I had a very similar situation, it feels that my system is running better with disabled GPU on Chrome. To do so, add the parameter --disable-gpu to the chrome command line:

/usr/bin/google-chrome --disable-gpu 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.