Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an 19-inch monitor with a 1366 x 768 native resolution and I'm using an ATI HD Radeon 5670. It does not detect my native resolution automatically, so I've put something like this on my xorg.conf (except for the numbers 1-9, I've put in the result of running cvt).

Section "Monitor"
    Identifier    "DVI-0"
    Modeline "1368x768_60.00"  1 2 3 4 5 6 7 8 9 -hsync +vsync
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "DVI-0"
    SubSection "Display"
        Modes       "1368x768_60.00"
    EndSubSection
EndSection

Section "Device"
    Identifier    "Card0"
    Driver        "radeon"
EndSection

So my resolution changes, but the problem is the resolution does not fit well to the screen. Seems like some pixels to the top (around 10px) are not viewable, and the width does not fit as well, there are huge black spaces on the left and right of the screen. Adjusting width settings on monitor messes up my font. On Windows, 1366x768 works very well, any ideas how to fix this?

share|improve this question
1  
What is the monitor model? What drivers are you using with the card? Are you dual booting, so you could test the same card and monitor in Windows? –  Tanel Mae Apr 17 '13 at 14:40
    
I'm using Samsung SA300 19 in monitor. I'm currently using radeon driver on arch linux. –  mumble Apr 18 '13 at 13:50
    
And on Arch it works fine? Have you checked how the system detects the monitor (could you also test it without your xorg.conf edits)? Look into /var/log/Xorg.0.log and you should see the detected monitor name, serial no, modelines and etc. How is it detected there? You could add relevant lines from there to your question. Also which radeon packages you have installed on Ubuntu? Are they installed from Ubuntu main repository or from Ubuntu-x-swat? –  Tanel Mae Apr 21 '13 at 12:46

1 Answer 1

Here is a line for your /etc/X11/org.conf that worked for me taken from this post.... askubuntu-link In my particular case I had to fiddle around with the viewport numbers to get everything just right. The most relevant part is the {ViewPoutOut...... part. If you add that to your modeline and change relevant numbers, then fiddle with the offsets, you should be ok.

Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: 1920x1080 { ViewPortOut=1820x1020+50+30, ViewPortIn=1920x1080 } +1600+0"

Something like this added to the end of your xorg.conf might be a good place to start:

Option "metamodes" "DVI-0: 1368x768 { ViewPortOut=1350x758+20+20, ViewPortIn=1368x768 }"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.