Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my specs

sudo lshw -C network

  *-network DEAKTIVIERT   
       Beschreibung: Kabellose Verbindung
       Produkt: Centrino Wireless-N 2230
       Hersteller: Intel Corporation
       Physische ID: 0
       Bus-Informationen: pci@0000:03:00.0
       Logischer Name: wlan0
       Version: c4
       Seriennummer: 60:36:dd:0f:cb:52
       Breite: 64 bits
       Takt: 33MHz
       Fähigkeiten: pm msi pciexpress bus_master cap_list ethernet physical wireless
       Konfiguration: broadcast=yes driver=iwlwifi driverversion=3.5.0-27-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       Ressourcen: irq:46 memory:f4700000-f4701fff

Here's what I've tried so far

I checked if there was a hardware of software block, there isn't:

rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

I tried to clean the interfaces-file

gksu gedit /etc/network/interfaces

but there was nothing writen in the file except:

auto lo
iface lo inet loopback

I checked if the "iwlwifi"-module is loaded, however I'm not sure what the output means.

lsmod |grep iwlwifi
iwlwifi               399576  0 
mac80211              555272  1 iwlwifi
cfg80211              208382  2 iwlwifi,mac80211

I assumed that the "0" in the first line of the output means, that "iwlwifi" is not loaded. So I tried to run "iwlwifi" with the "modprobe"-command.

sudo modprobe iwlwifi -r 
sudo modprobe iwlwifi 11n_disable=0

I'm dualbooting Windows on this machine, and in Windows the wifi works just fine. The router also works obviously.

I don't know if this important, but I disabled my Bluetooth by default a few days ago by editing rc.local with

rfkill block bluetooth 

(but the wifi worked the following two days)

I also installed VirtualBox a few days ago (since I've read about network problems after installing VBox, I wanted to mention this), but only tried to install Windows 7 as a guest. And although the symbol for the nm-applet is not visible, I checked synaptic package manager and nm seams to be installed.

Your help is very much appreciated.

PS: The output is in partly in German. DEAKTIVIERT (after the lshw command) means DISABLED, everything else seams to be the normal output.

Checking the message logs:

dmesg | grep iwl
[    3.427995] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[    3.427999] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[    3.428189] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[    3.428193] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900057bc000
[    3.428196] iwlwifi 0000:03:00.0: HW Revision ID = 0xC4
[    3.428350] iwlwifi 0000:03:00.0: irq 46 for MSI/MSI-X
[    3.618390] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1
[    3.618701] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[    3.618707] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    3.618710] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[    3.618712] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[    3.618715] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P disabled
[    3.618719] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Wireless-N 2230 BGN, REV=0xC8
[    3.618840] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[    3.637741] iwlwifi 0000:03:00.0: device EEPROM VER=0x81c, CALIB=0x6
[    3.637748] iwlwifi 0000:03:00.0: Device SKU: 0x150
[    3.637752] iwlwifi 0000:03:00.0: Valid Tx ant: 0x3, Valid Rx ant: 0x3
[    3.637777] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[    3.652582] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   74.692031] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
[   74.692034] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[   74.692146] iwlwifi 0000:03:00.0: pci_resource_len = 0x00002000
[   74.692148] iwlwifi 0000:03:00.0: pci_resource_base = ffffc900057bc000
[   74.692150] iwlwifi 0000:03:00.0: HW Revision ID = 0xC4
[   74.692276] iwlwifi 0000:03:00.0: irq 46 for MSI/MSI-X
[   74.696282] iwlwifi 0000:03:00.0: loaded firmware version 18.168.6.1
[   74.696623] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   74.696628] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   74.696631] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   74.696634] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE enabled
[   74.696637] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_P2P disabled
[   74.696641] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Wireless-N 2230 BGN, REV=0xC8
[   74.696752] iwlwifi 0000:03:00.0: L1 Enabled; Disabling L0S
[   74.713452] iwlwifi 0000:03:00.0: device EEPROM VER=0x81c, CALIB=0x6
[   74.713456] iwlwifi 0000:03:00.0: Device SKU: 0x150
[   74.713458] iwlwifi 0000:03:00.0: Valid Tx ant: 0x3, Valid Rx ant: 0x3
[   74.713475] iwlwifi 0000:03:00.0: Tunable channels: 13 802.11bg, 0 802.11a channels
[   74.713774] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
share|improve this question
    
I suggest you try 11n_disable=1. Also, look for clues as to why it's DEAKTIVIERT. Check the message logs with: dmesg | grep iwl. –  chili555 Apr 14 '13 at 12:56
    
@chili555 : thanks. 11n_disable=1 unfortunately didn't work either is there anything specific i have to look for in the logs? –  soulistheanswer Apr 14 '13 at 14:57
    
We have to look for something wrong which we don't see here, unfortunately. Everything, so far, looks just fine. Please reboot with any ethernet cable detached and run: dmesg > dmesg.txt. Hook up the ethernet so you can connect and paste the dmesg.txt file here so we can look a bit deeper to see what is wrong. pastebin.ubuntu.com Then give us the link. –  chili555 Apr 14 '13 at 15:34
    
here's the pastebin link: pastebin.ubuntu.com/5708578 –  soulistheanswer Apr 14 '13 at 19:15
    
Please confirm your virtual machine set-up. Is Ubuntu the guest or host? Is Network Manager running? ps aux | grep -i network. Does the applet appear if you start it? sudo service network-manager restart. –  chili555 Apr 14 '13 at 20:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.