Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have searched through a lot of questions but it looks that nobody had the same problem.

I have successfully installed Ubuntu 12.10 on my MacBook (mid 2009) from a burned DVD. While keeping a 450 G partition for Mac OS X, I have created a main 150 G partition for Ubuntu, a 2G swap partition, and finally a small partition for bios-grub, since it didn't want to continue the installation if there were none. I remember having set the boot loader to the 150 G Ubuntu partition, but without really being sure of what I did.

When I restart my computer, the rEFIt menu gives me the choice between OS X and Ubuntu, but when I choose Ubuntu the only thing I get is a black screen with a blinking cursor... At least I didn't ruin my OS X, but I have tried tho reinstall it the same way and I got exactly the same result. Do you know what I could have done wrong ? Thank you for your help.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

First, unless you've got a fairly elderly Mac with a 32-bit EFI, you're better off with a 64-bit version of Ubuntu. Although you can boot a 32-bit version of Linux on a 64-bit Mac, doing so restricts your boot loader options and may require you to jump through some extra hoops. This may be what you're running into, so scrapping your new installation in favor of a native 64-bit installation may be in order.

Second, my suspicion is that you're booting in BIOS mode but you lack a hybrid MBR. This is an ugly hack that Apple uses to, among other things, activate the BIOS emulation (aka CSM) in the Mac's firmware. You may be able to get the system booting by creating a hybrid MBR with gdisk (part of the package of the same name in Ubuntu, IIRC); see my first link for detailed instructions on doing this.

Third, if you switch to a 64-bit version of Ubuntu, IMHO you're better off without a hybrid MBR. Instead, you should install an EFI-mode boot loader for Linux and boot with that. (Unfortunately, it's easier to install Ubuntu in BIOS mode, so you'll need to do this after installing Ubuntu.) Macs are a bit weird, though. Your best bet may be to switch from rEFIt (which hasn't been updated in three years) to its more recent fork, rEFInd. rEFInd can launch a Linux 3.3.0 or later kernel directly, without involving GRUB. This is most easily done if you install an EFI filesystem driver for whatever filesystem you use on Linux's /boot partition (or the root partition if you don't use a separate /boot) and create a /boot/refind_linux.conf file. This is all described in the rEFInd documentation.

share|improve this answer
    
Thank you, it worked for me ! The blank screen was fixed with the 64bit version, which displayed a more explicit "No operating system found". And then I created a hybrid MBR to fix everything. However, I didn't really understood how to boot Linux without GRUB with rEFInd. –  Romain Apr 17 '13 at 6:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.