Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been recently trying to play Age of Empires 2 on my Linux Ubuntu 12.04 LTS computer. However, I can't seem to get it to work with any method i found on the computer. I've tried Playonlinux, however, when i try to play it, a message comes up saying that there has been an internal error. I've also tried doing it though virtualbox and installing it onto a virtual version of windows xp. However, after it completes the install, it tell me that there is no CD in the disk drive and that I should insert it and restart the application. If anyone has a way I haven't tried yet or something that I could have missed please let me know. Thanks.

share|improve this question

2 Answers 2

You should give WINE a look. WINE has come a long way over the last few years and many Windows-based applications can be run on it with varying degrees of success.

Here is the WINE HQ page for Age of Empires 2:

It looks like Age of Empires 2 has a pretty good rate of success. To get WINE, you first need to add the WINEHQ PPA Repository by adding "ppa:ubuntu-wine/ppa" as a software source from within the Ubuntu Software Center (Edit->Software Sources). Then you should be able install WINE by executing the following from Terminal:

sudo apt-get install wine1.5

For further instructions, see WINE For Ubuntu and Ubuntu Derivatives

share|improve this answer
    
Ok I installed wine. Now, how do I add the game into wine? –  user149131 Apr 14 '13 at 18:41
    
If you haven't installed it yet, navigate to the setup/install program on the media, right-click and select "run with Wine." That should install it in your ~./wine/drive_c/Program\ Files directory. If you run into trouble, check the WINEHQ FAQ for installing Windows applications: wiki.winehq.org/… –  BryceAtNetwork23 Apr 14 '13 at 23:25
    
Well, I've managed to install the game with wine. However, when I try to run it, it gives me the loading screen for the game, then it goes away followed by wine and then nothing happens. Could the files have made it into the wine program files for some reason? –  user149131 Apr 15 '13 at 0:39
    
I meant not have made it –  user149131 Apr 15 '13 at 0:48

You should check the WineHQ forums for instructions about how to make it work. Most of the games need some tweaking or some native libraries to work fine. I'm not sure if it's right linking to another webside, but here's some information:

http://appdb.winehq.org/objectManager.php?sClass=application&iId=99

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.